• 0

Dependency on libRoboRIO_FRC_ChipObject.so.19


Question

We are updating last years robot to use some of the DMC60c controllers and it appears the libraries for the configuration tool and the robot code need the shared library libRoboRIO_FRC_ChipObject.so.19.  Is there an easy way to update to version 20, or even 2021 when it is release?  I have found some of the code, but it does not appear it is all on github to allow for that update by the end users.

Error in running code:

 java.lang.UnsatisfiedLinkError: /usr/local/frc/third-party/lib/libDMC60CDriver.so: libRoboRIO_FRC_ChipObject.so.19: cannot open shared object file: No such file or directory

 

Thanks!


Randy

 

Edited by RSteiner
typo
Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now