• 0

Mac "hanging" with new versions of waveforms.


Question

I was running an older (2-3 years) version of waveforms with OS 10.14.6 on a 2012 macbook pro and all was great.  I switched to Waveforms 3.17 to get the curve tracer function anf I get the "spinning beach ball" a lot.  Sometimes it lasts a few seconds other times I need to force quit and restart.  I tried the latest beta version of 3.17.21 with the same issue and then went back a release to 3.16 and it still gets stuck.

I have restarted the computer,  quit other programs and done repeated installs and it still hangs.  It will run a continuous bode plot for an hour but the minute I try to change a parameter It occasionally gets hung up with the beach ball.

Does anyone know that the first version was with the tracer function?

dave

Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0
Posted (edited)

It doesn't typically "crash" rather the spinning beach ball continues for more than a few minutes and I force quit in order to restart and finish working.  I'll try to get it to "stall" and leave it until it crashes to get a report.  I do not recall actually crashing since I backed down from 3.17 to 3.16. 

 

Edited by dave slagle
Link to post
Share on other sites
  • 0

Hi @dave slagle

Could it be a USB connection issue so the device gets occasionally disconnected? In this case a disconnect error should pop up quickly.
It could also be an under-voltage or over-current problem so part of the device gets reset. In this case it could take longer for the error to show up.
See the system monitor on the right of the status bar. The USB voltage should be above 4.5V and the current in idle ~350mA. You could try to use 5V DC aux power supply.

Edited by attila
Link to post
Share on other sites
  • 0

The odd thing is this never happend before I went from 3.10.9 which has run flawlessly for years to 3.17 then 3.16.  I'll try 3.10 again and see if the problem persists.

I first loaded 3.17 on an  Imac running 1OS 10.15 and it also hung up.... At the time I thought that was from a lack of processing power since I have a few other programs that also run slow on it but now I see a pattern happening with older (2012/2013) macs.

what version was the first to have the tracer function?

dave

Link to post
Share on other sites
  • 0

Hi @dave slagle

3.16.11
digilent.waveforms_beta_v3.16.11_64bit.exe
digilent.waveforms_beta_v3.16.11_32bit.exe
digilent.waveforms_beta_v3.16.11.dmg
digilent.waveforms_beta_3.16.11_amd64.deb
digilent.waveforms_beta_3.16.11.x86_64.rpm
digilent.waveforms_beta_3.16.11_i386.deb
digilent.waveforms_beta_3.16.11.i686.rpm
Added:
- Curve Tracer instrument

 

Link to post
Share on other sites
  • 0

Hi @dave slagle

I was running today for several hours the Impedance Analyze with AD2 on MBP late 2013 v10.15.7 without any issue.

You may try with a newer software version (>3.16.31 but preferably the latest) to reprogram the USB controller.
Disconnect the AD2, open WF Device Manager, press "My device is not listed", connect the AD2, press Find Device, make sure the AD2 is detected, press Program Device. Reconnect the AD2.

 

Link to post
Share on other sites
  • 0

Went to 3.18.10 and reset the device and it still hangs.  I'm on OS 10.14 on a Retina LAte 2013 MBP... I cant go up to 10.15 because i'll lose all my 32 bit software.

 

I have noticed it happens when the program has been doing sweeps for a bit.  If left running it will sweep the bode plots for hours but when I return after a minute or two and try to make a change it hangs.  The computer is in use so it is not a sleep thing.  Once it is working I can make changes to levels or whatever without issue.  It also seems the longer it is idle without a change of anything the longer it takes to "wake up"  It almost seems as if the program goes to sleep and takes a long time to wake.

 

 

Screen Shot 2022-01-06 at 2.49.04 PM.png

Link to post
Share on other sites
  • 0

More info.

Ver 3.10 runs bode sweeps for hours in and out of sleep/wake  without a pause or hiccup.  When ver 3.18 hangs it stays stuck on a single tone until the beach ball stops spinning then it continues to sweep. 

other observations:

-if left sweeping for 5 minutes and then the mouse is moved it hangs for 5-10 seconds then continues.

-If left sweeping until the computer goes to sleep it took 3 minutes of spinning beach ball to resume.

-If the AD2 is plugged in the green LED flashes at a constant rate independent of the software function.

Link to post
Share on other sites
  • 0

Hi @dave slagle

I'm unable to reproduce beachball...
For me the WF app seems to be paused after one minute the Mac goes to sleep (I've connected a LED to an AD2 output controlled from software). The software resumes immediately on wakeup and reacts to the inputs/adjustments fine.

On you machine it could be a low level USB driver / hardware issue, like something related to USB suspend...

@malexander Do you have MacOS 10.14 to test sleep/wakeup ?

You could try to disable the auto Reconnect option to reveal eventual communication error.

image.png.0d90e02034120734be624219fdf2652e.png

Link to post
Share on other sites
  • 0

Unclear if the Disable the auto reconnect was for me but I disabled it and no difference.  I also have a brand new AD2 that I tried and the same thing.  

Swapped cables... same thing.

this was all on a Macbook Pro Retina 15"  2.3gHz i7 Late 2013 running 10.14.6

Also went to a 27" imac  3.2gHz i5 Late 2013 running 10.15.7 same thing.

All of this is while running Bode plots in the network function.

I went to the signal generator looped back to the scope and same thing on both computers.

dave

 

Link to post
Share on other sites
  • 0

@attila

Unfortunately, I don't have that version of OSX installed anymore. The MacBook pro is on 11.4 and I just upgraded the M1 based MAC Mini to 12.1 to work through a different support question.  I'm not sure how to install it natively... there's no optical drive on the MBP and I don't have the disc image. Maybe we can run it in VM?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now