Digilent Agent Win 10 update issue??

Recommended Posts


Is anyone else having new problems communicating with an Openlogger device using Digilent Agent. I can't get past the Error connecting to Digilent agent message.

I have two boards, both of which used to work on three W10 computers. Neither of these boards work on any of those PC's now.

However, both still work on an old (not recently updated) W10 laptop. (Same cable used on all tests).

Edge, and Chrome browsers both tested.

Device manager reports same USB driver on working and non-working machines.

Same version of Agent 1.2.3 on all machines and have tried uninstall-reinstall.

Beginning to suspect a Windows update is interfering with the operation of Agent software - anyone else experienced the same or can shed any light?

Many thanks for any thoughts.



Link to post
Share on other sites

quick update on this.

Have found using http://localhost:42135 direct into browser works now, but took a couple of attempts to see the board.

Same setup through webpage still does not work, at home and work (different security settings). Have tried fully disabling AV and firewall with no success.

Still be interested to know if anyone else has encountered same.



Link to post
Share on other sites

Hi @MA00,

I dug out my OpenLogger and had a look myself but found that everything was working fine. Can you enable logging in WFL and open the browser developer tools, then try to connect. There should be some output that appears in the console, and I would appreciate it if you could share a screenshot or text dump if it with me. You might also try running the agent as an administrator and see if that provides any results.


Link to post
Share on other sites


Both of my boards have now been tested on five W10 computers, on one I get a 404 error.

On all the others I now get same behaviour. Board is not recognised by waveformslive, but is detected if localhost is used.

However, I cannot progress past the first screen:

Instrument panel briefly displays connecting to device before returning to same screen.

Configure does not respond in any way

Documentation reports device model unknown

Remove seems to function as normal


On the initial connection I am able to reinstall firmware. (1.3.0) as have been using all along.

Nothing is shown for Wifi status, and if I select Wifi, no connections are detected. If I manually my own network details it reports an error.

Have tried (re)re-installing agent and running as admin.

Tried software on XP and Vista machine but these do not run Agent - trying to get win 7/8 machine to try.

Computer I am currently using reports FTDI driver - which I believe is correct?

I am not sure what I need to do enable WFL logging - is there an up to date guide I can follow.


One of the boards was set for standalone boot operation, and still performs this function correctly. I have operated and downloaded valid data today.

The other board was put away as a (tested/working) spare several weeks ago.

I am very puzzled why I have two boards, used in different scenarios, which appear electrically OK, are recognised by USB, can accept firmware update - but neither of which can now work with agent/waveforms live to allow me to get to a point to update the configuration. (sample rate & duration).


I have seen a reference to using Putty to talk to a board - is this something I could try?

The documentation suggests only W10 environment to run the software, but lists Mac/Linux version of Agent. Is there another platform I could test on?


Any further suggestions very gratefully received.

Thanks, Martin








Link to post
Share on other sites

Hi Martin,

It looks like some changes have occurred in the Chrome browser and others based on it that is breaking some things. You can correct it by going to the chrome://flags page, and setting the 'Block insecure private network requests' to Disabled. This flag is preventing requests made to localhost from sites available on an external IP address, ie waveformslive.com. Continuing to visit the http://localhost:42135 address will also work and has the same functionality of waveformslive.com, if setting a configuration flag in your browser isn't something you want to do. I have noticed that Firefox doesn't seem to have this issue, and I suspect other non-Webkit based browsers will also not experience this issue. I'm not aware of any solutions to account for these changes in browser behaviour, but I will say up-front that we have stopped putting developmental effort into these products and won't be updating the software should any solutions come to light.

It also appears that your local WFL version is out of date. To update it, download the latest build from here and extract its contents to C:\Users\<username>\AppData\Local\Digilent\Digilent Agent\www, replacing <username> with that of your Windows 10 username.

For future reference, you can enable logging in WaveForms Live by expanding the sidemenu on the Device Manager page, going into Settings, expanding Advanced and clicking on the Change Console Log button. Choose Console or Both in order for output to appear in the browser developer tools, which can be opened by right clicking on the web page and clicking Inspect.

As for PuTTY, that can be used to bypass the agent and communicate directly with the device, and is helpful for determining its functionality. Since your issue is getting the browser to communicate with the Agent, PuTTY isn't going to much help to us at the moment.

OpenLogger is only supported on Windows, but OpenScope is supported by Mac & Linux, which is why you see those listed as well.


Link to post
Share on other sites

Hi Andrew,

I have just tried the latest build WFL as suggested - this worked first time on my home PC - will try with the other board on works PC's tomorrow.

For my understanding, (& to allow me to explain the issue to my boss) Is this summary correct - A change in the browser has prevented access to the live version of the software, as such I have resorted to an outdated version of the hosted WFL which does not function as intended with the open logger. Updating the hosted version (or changing browser) has/will correct the issue.

Many thanks for taking the time to get to the bottom of this issue and the explanation.

Much appreciated.



Link to post
Share on other sites

The summary isn't quite correct. A change in Chrome security policies is preventing the browser from communicating with the Agent when accessing the live version of the site. Using the locally hosted version of the website skirts around these updated security policies, but required updating the static assets served by the local server to a version that supports OpenLogger. Using a different browser (such as Firefox) will allow use of the live version of the site, provided it isn't using the same browser engine as Chrome.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now