• 0
rappysaha

Nexys 4 DDR is not working

Question

HI, I am very new to Nexys4DDR.

according to the tutorial, I try to run the board. But it's not working.

1) JP3 and JP1 connection is checked.

2) Use Prog UART port for programming

3) In Vivado, board_files were loaded

Every time I run implementation without any error. But when I upload the programme, that is attached, the LD21 and LD22 is going to turn on but nothing happened according to the programme. 
 

just this thing is showing at TCL console:

WARNING: [Labtools 27-3123] The debug hub core was not detected at User Scan Chain 1 or 3.

According to the program when I turn on the sw0, the led0 should turn on. But nothing is going to turn on after turning on sw0. 

I tried very hard just to make a simple code with it. But I can't. If anyone can give me any suggestion. It will be highly appreciated.  

Thank you.

top.vhd

cake.vhd

Nexys4_Master.xdc

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hello,

The problem is that you used the XDC file for Nexys4, not for Nexys4DDR. Here you can find the XDC for your board. Also, Even if Vivado isn't case sensitive, the constraints are. I suggest you to name your signals according to the XDC file, or change the name in the XDC to match your code exactly.

Best regards,

Bianca 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now