• 0

Trying to find correct board files/ board packages for older Zybo board


Question

I bought a Zybo board a few years ago (this is not the Z7, this is the older original Zybo). The board number is PB200-279 RevB (Serial # DA42A4E) and the board has a copyright from 2013 on it. I've been trying to load some demos and I've tried a few things (namely both board revisions that seem to be available for the original Zybo, both the B and B.4 revisions loaded from the vivado-board-master.zip (both old and new config folders). I can build the "hello world" zynq demo all the way to the sdk (with UART1 configured for pins 48 and 49 as per the manual) and program the bitfile, but when I try to run the .elf on top of that [using both B and B.4 support packages] I get AHB transaction errors (attached) and the program does not run (or when it does, the UART terminal appears to produce gibberish). My internal UART configs are 115200, I am using the Zynq UART1, and I only have a Zynq module and nothing else in my block diagram.

One thing I did notice about the board is the memory on it is the ISSI IS43TR16128B-125KBL, not Micron MT41J128M16JT-125 or MT41K128M16JT-125 as specified in the documentation (not sure if this matters for config purposes). I don't see a schematic showing this part or any reference to it anywhere for any Zybo boards, but using micron's competitor tool it appears to be compatible with some similar micron ddr parts

If someone has a Zybo of a similar vintage and could point me towards the proper vivado config files (or the proper method for getting hello world working on this board with Vivado 2017.4), I would be much obliged. I've looked all over the place and I don't see anything about additional required DDR3/DDR3L configs for any version of the Zybo (the ISSI modules appear to be DDR3L, not DDR3, although I'm not sure if this matters for configuration purposes).

Capture2.JPG

Capture.JPG

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0
Posted (edited)

Nevermind! I figured it out. Rev B worked the whole time and SDK "hello world" now prints from the terminal perfectly - the Zynq module simply needed the input clock set to match the board 50Mhz (For some reason the Zynq peripheral defaults to 33MHz, which is incorrect for how the Zybo boards are configured)

MAKE SURE ZYNQ INPUT CLOCK FREQUENCY IS SET PROPERLY to 50MHz for Zybo.JPG

Edited by zakkjf
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now