• 0

Help with an Adept error dialog


Question

So, I got this dialog box when I tried to use the Adept to program a custom Spartan 6 board:

The Device this configuration file was made for is not known. Associate Config File with device anyway?  

Hmm, I created the *.bit file from the Xilinx ISE 14.7 software suite and I made a *.mcs file from the Impact application, so I'm wondering how Adept associates files anyway?

The Setup:

The board is a custom Spartan 6 board, with routes between a Spartan 6 tq144 fpga and a s25fl128 flash. The jtag ports of the Spartan 6 fpga are configured to a header, where I connect a jtag-hs2. Please note, that I've pull ups (100k resistors) on TDI, TDO, and TMS. A pull down (100k resistor) is on the TCLK pin.  

The Firmware:

I've created a simple pass through from one pin to another, it 'compiled' successfully with no warnings or information statements. I was able to then generate a *.bit file with no issues. 

The issue:

I used Impact to initially try and program the board. I 'know' I got a successful connection, because the Get device ID option worked and it correctly identified the flash and fpga configuration. When it came to uploading the bit-stream, it failed with "Done did not go high' error. So, I decided to try the Adept software..... and I got the aforementioned Dialog box. I did press the "OK" button and the status console on the Adept software stated that it was 'successful.' However, the board was obviously not programmed. By the way, I have the mode pins set at 00.  So, I'm wondering if I've not setup the mode pins correctly, missed a setup step on Impact or the ISE? 

Any questions or answers to help me along would be great. Love to learn!

Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now