SPI and serial communication in LabVIEW LINX


Recommended Posts

Hi All,

 

I'm trying to read Thermocouple value using MAX6675 board through LabVIEW LINX, and also trying to control speed of stepper motors ( 2 no's) through LINX. I have done two programs for reading temperature data and controlling of speed of stepper motor through LINX.

The programs individually works fine, but there is problem when two programs are combined together. 

The problem is that it makes stepper motor to stall or have jerky operation during VI execution. Can anyone help me to sort out the problem.

Link to post
Share on other sites

Hi @priya,

My guess would be that the act of sending different messages and sending different protocols is resulting in some delay within LabVIEW LINX, making the stutters in the stepper motor, as there is a lot of handshaking (talking back and forth) between a system board and LabVIEW. I don't know what board you have, but you may be able to set up a custom command where you have a premade function on the host board and then LabVIEW triggers it through only a single message/1 byte communication instead of a multi-byte situation. The folks on the NI LINX forum, https://forums.ni.com/t5/LINX/bd-p/linx-toolkit?profile.language=en, may be able to help you more.

Thanks,
JColvin

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now