• 0

[Arty Z7-20] No console output from debugger


Go to solution Solved by JColvin,

Question

I don't know what happened.

A few days ago - at the time I was using Vitis+Vivado 2019.2 - I launched a debug session and the Console had no output to be seen. I imagined I selected the wrong console: the zynq seems to export two terminals

"TCF Debug Virtual Terminal - ARM Cortex-A9 MPCore #0" and "TCF Debug Virtual Terminal - ARM Cortex-A9 MPCore #1".

Bummer. I was on the right console. There was no output anywhere.

I checked the settings. At first, I couldn't notice anything wrong. I eventually went nuclear and decided to upgrade to 2020.2. A very bad idea.

I eventually managed to install 2020.2 on a brand-new Linux VM and launch the hello world application. The breakpoints are hit correctly but there's no console output. I checked again the settings. If I go in the platform project associated to the application I can confirm configuration for "standalone" has stdout set to ps7_uart0.

I even went back into Vivado Block design and checked my zynq block settings. I'm not 100% sure I read correctly but they seem to be enabled on MIO14 and MIO15 as they always have been. The pins are highlighted green on the floorplan from the ZYNQ7 customization panel (attached, to clarify).

I figured I could ask here. What am I missing?

 

 

pins.png

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
  • Solution

Hi @MaxDZ8,

MIO 14 and MIO 15 are the correct pins for UART 0. I just ran the built-in example Hello World for Arty Z7-20 project successfully, though I used an external serial terminal (TeraTerm) to connect to the board and see the serial output.

As for the built in Vitis/SDK serial terminal, I'll usually have trouble getting it play as nicely as I would like, so I usually use a different serial terminal like Tera Term or PuTTY to see the output.

Let me know if you have any questions.

Thanks,
JColvin

Link to post
Share on other sites
  • 0

Thank you, I forgot about Tera term.

It seems my COM settings were reverted to 9600 somehow. Once I set back Tera Term to 115200 it worked just fine. I'd like to know what happened and how to permanently fix it but all things considered I'll just follow your suggestion, the terminals in Vitis are unconvenient anyway.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now