• 0
AdamZ

Nexys Video No Hardware Target Exists

Question

I am trying to operate the Nexys Video development board using the vivado hardware manager on a windows 8 system. However I keep getting  No hardware targets exist on the server error. Steps i have taken to remedy the situation include:

  • Re-installed Vivado with included cable drivers
  • Tried different versions of vivado
  • Tried on a different PC
  • Formatted PC and installed vivado
  • Updated FTDI drivers
  • Tried 3 different (new) USB cables
  • Installed cable drivers manually

The programming jumper is in the right position (jtag), the USB cable is plugged into the correct (prog) port and the board is powered. Can anyone suggest anything else I might try to fix the issue?

 

Thanks. 

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 0

Hello,

After connecting the board (prog port) and powering it on, how is the board recognized by the PC? Please check the USB tree and send us a screenshot.

Sergiu

Share this post


Link to post
Share on other sites
  • 0

It seems to be recognized fine. I have attached an image of the USB tree when board is plugged (left) and when unplugged (right). 

 

Thanks.

before after.png

Share this post


Link to post
Share on other sites
  • 0

For Nexys Video the USB Serial Converters are not supposed to show up as COM ports.
Under USB Serial Converter ( A and B ) properties uncheck the Load VCP option and reconnect the device.

Please check if the device is recognized by Adept Application. This is installed by Adept System: https://reference.digilentinc.com/digilent_adept_2

Which USB driver version do you have installed ?

Which Vivado version are you using ?

 

Edited by attila

Share this post


Link to post
Share on other sites
  • 0

I am using USB driver version: 2.12.16.0

I am Working with vivado 2015.4.  I have also tried 2015.1 and 2016.1. 

The board does not show in adept. It shows no devices connected. 

Unchecking vcp made the com ports disappear. But vivado still gives the error and the board is still not seen in adept.

Edited by AdamZ

Share this post


Link to post
Share on other sites
  • 0

Problem solved. The USB eeprom reconfiguration did the trick. Previously I was not selecting the correct setting for the development board.

MANY thanks for your invaluable help. 

Share this post


Link to post
Share on other sites
  • 0

hello,

    i have the same problem,Can you tell me in detail how did you solve the problem?The following is my description of the problem:

          I use the FPGA board is nexy Nexys Video A7 board, want to achieve usb and PC information transmission, want to use the synchronization fifo mode,I used FTDI software (FT_Prog.exe) to eeprom into 245fifo mode, but vivado since then show the link is not the device, bit file can not be written. I have two the same board, another board did not eeprom configuration before, vivado can link to the equipment, but after the configuration also appeared in this issue, is not my configuration eeprom there is a problem?Here's my screenshot of the problem。                                                                                                                                                                                                                                                         wang

4.png

3.png

2.png

1.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now