• 0

There is an error information while programming bitstream file into Flash memory on NetSume board ?


Dear Sir,

 I just buy a NetSume FPGA board, but I don't know how to program bit file into Flash memory.

First things first, I checked that JP1 is not shorted. Then I run  through this guide: https://github.com/NetFPGA/NetFPGA-SUME-public/wiki/Reference-Operating-System-Setup-Guide. After I complete it, I run the following command at the terminal:

dsumecfg write -d NetSUME -f production_test.bit -s 0 -verify

Error information is following:

Configuring FPGA...
FPGA configuration succeeded.
Erasing Flash: 0%ERROR: timed out after 25000ms while waiting for FPGA handshake
ERROR: FPGA handshake failed while erasing blocks blocks 0 - 5

It is also possible that the CPLD XC2c512 was erased when I run the following command at the terminal:

djtgcfg  erase -i 1 -d NetSUME

How can I resolve the problem if  this is the case?

You can see the error information in the following picture . Does anyone have any suggestions for the problem?   Thanks in advance.

flash error.png



Edited by wangmengsail
Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hi @wangmengsail,

The folks on the NetFPGA SUME mailing list will be best able to help you with SUME applications as they maintain the materials and GitHub for it. You should already have access to the mailing list when you signed up to get access to the GitHub materials.

Let me know if you have any questions.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now