• 0
Sign in to follow this  
HereAndNow

How to setup diligent usb to serial cable on CentOS 6?

Question

How to setup diligent usb cable for Xilinx Spartan-3 starter kit on CentOS 6?

I have already installed ISE WebPack, digilent.adept.runtime, digilent.adept.utilities, libCseDigilent, fxload, and some other packages.

lsusb shows:

[lukasz@localhost home]$ lsusb
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 006: ID 03fd:000d Xilinx, Inc. 

but djtgcfg shows nothing:

sudo djtgcfg enum
No devices found

iMPACT log:

Welcome to iMPACT
iMPACT Version: 14.7
Project: /home/lukasz/VHDL/QLIW//auto_project.ipf created.
// *** BATCH CMD : setMode -bs
// *** BATCH CMD : setMode -bs
// *** BATCH CMD : setMode -bs
// *** BATCH CMD : setMode -bs
GUI --- Auto connect to cable...
// *** BATCH CMD : setCable -port auto
INFO:iMPACT - Digilent Plugin: Plugin Version: 2.4.4
INFO:iMPACT - Digilent Plugin: no JTAG device was found.
AutoDetecting cable. Please wait.
*** WARNING ***: When port is set to auto detect mode, cable speed is set to default 6 MHz regardless of explicit arguments supplied for setting the baud rates
PROGRESS_START - Starting Operation.
If you are using the Platform Cable USB, please refer to the USB Cable Installation Guide (UG344) to install the libusb package.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
File version of /opt/Xilinx/14.7/ISE_DS/ISE/bin/lin64/xusbdfwu.hex = 1030.
File version of /etc/hotplug/usb/xusbdfwu.fw/xusbdfwu.hex = 1030.
 WinDriver v10.31 Jungo (c) 1997 - 2011 Build Date: May 24 2011 x86_64 64bit 18:13:19.
Cable connection failed.
Connecting to cable (Parallel Port - parport0).
 WinDriver v10.31 Jungo (c) 1997 - 2011 Build Date: May 24 2011 x86_64 64bit 18:13:19.
Cable connection failed.
Connecting to cable (Parallel Port - parport1).
 WinDriver v10.31 Jungo (c) 1997 - 2011 Build Date: May 24 2011 x86_64 64bit 18:13:19.
Cable connection failed.
Connecting to cable (Parallel Port - parport2).
 WinDriver v10.31 Jungo (c) 1997 - 2011 Build Date: May 24 2011 x86_64 64bit 18:13:19.
Cable connection failed.
Connecting to cable (Parallel Port - parport3).
 WinDriver v10.31 Jungo (c) 1997 - 2011 Build Date: May 24 2011 x86_64 64bit 18:13:19.
Cable connection failed.
PROGRESS_END - End Operation.
Elapsed time =      2 sec.
Cable autodetection failed.
WARNING:iMPACT:923 - Can not find cable, check cable setup !

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hey HereAndNow,

The Spartan-3E starter board has JTAG circuitry that Adept is unable to recognize, so if you only have installed the Adept packages at the moment you won't be able to connect to your board. You will only be able to program this board through iMPACT. That being said, Xilinx has a USB installation guide that may be able to help you resolve your issue. The install instructions for Linux systems is on page 15. Please let us know if this fixed your issue, if not we can look into this in a little more detail.

Regards,

Nate

Share this post


Link to post
Share on other sites
  • 0

I've Xilinx drivers already installed. Of course i can do it once again:

[root@localhost Desktop]# cd install_drivers
[root@localhost install_drivers]# ./install_drivers
--Driver versions in this package: windrvr=900, xpc4drvr=1041
--Script name = ./install_drivers
--HostName = localhost.localdomain
--Current working dir = /home/lukasz/Desktop/install_drivers
--Script location = /home/lukasz/Desktop/install_drivers
--Kernel version = 2.6.32-573.el6.x86_64.
--Arch = x86_64.
--Installer version = 1053
--Unsetting ARCH environment variable.
--User has root permission.
--File /lib/modules/misc/install_windrvr6 does not exist.
--Installing USB drivers------------------------------------------
--File /etc/hotplug/usb/xusbdfwu.fw/xusbdfwu.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusbdfwu.hex version = 1030
--File xusbdfwu.hex exists.
--File xusbdfwu.hex version = 1030
--File xusbdfwu.hex is already updated.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xlp.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xlp.hex version = 1028
--File xusb_xlp.hex exists.
--File xusb_xlp.hex version = 1028
--File xusb_xlp.hex is already updated.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_emb.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_emb.hex version = 1028
--File xusb_emb.hex exists.
--File xusb_emb.hex version = 1028
--File xusb_emb.hex is already updated.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xpr.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xpr.hex version = 2004
--File xusb_xpr.hex exists.
--File xusb_xpr.hex version = 2004
--File xusb_xpr.hex is already updated.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xup.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xup.hex version = 1030
--File xusb_xup.hex exists.
--File xusb_xup.hex version = 1030
--File xusb_xup.hex is already updated.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xp2.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xp2.hex version = 2300
--File xusb_xp2.hex exists.
--File xusb_xp2.hex version = 2300
--File xusb_xp2.hex is already updated.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xse.hex exists.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xse.hex version = 2006
--File xusb_xse.hex exists.
--File xusb_xse.hex version = 2006
--File xusb_xse.hex is already updated.
--Product ID 0007 is already in the usermap.
--Product ID 0009 is already in the usermap.
--Product ID 000d is already in the usermap.
--Product ID 000f is already in the usermap.
--Product ID 0013 is already in the usermap.
--Product ID 0015 is already in the usermap.
--Product ID 0008 is already in the usermap.
--File /sbin/fxload exists.
--Installing windrvr6---------------------------------------------
--Checking version.
--File /lib/modules/2.6.32-573.el6.x86_64/kernel/drivers/misc/windrvr6.ko exists.
--File /lib/modules/2.6.32-573.el6.x86_64/kernel/drivers/misc/windrvr6.ko version = 1.3
--File LINUX.2.6.32-573.el6.x86_64.x86_64/windrvr6.ko does not exist.
--Setting source version to 900.
./install_drivers: line 213: [: 1.3: integer expression expected
--File LINUX.2.6.32-573.el6.x86_64.x86_64/windrvr6.ko is already updated.
--Module windrvr6 is not running.
--Restarting module.
--No old entry in /etc/rc.local
--Did not add install_windrvr6 script to /etc/rc.local.
--install_windrvr6 rc = 0
--Installing xpc4drvr---------------------------------------------
--Checking version.
--File /lib/modules/2.6.32-573.el6.x86_64/kernel/drivers/misc/xpc4drvr.ko exists.
--File /lib/modules/2.6.32-573.el6.x86_64/kernel/drivers/misc/xpc4drvr.ko version = 1041
--File xpc4drvr.ko does not exist.
--Setting source version to 1041.
--File xpc4drvr.ko is already updated.
--Module xpc4drvr is running.
--No old entry in /etc/rc.local
--Did not add install_xpc4drvr script to /etc/rc.local.
--install_xpc4drvr rc = 0
--Module windrvr6 is not running.
--Module xpc4drvr is running.
--Note: By default, the file permission of /dev/windrvr6 is enabled for the root user only
  and must be changed to allow access to other users.

--Return code = 0
[root@localhost install_drivers]# chmod 666 /dev/windrvr6 

 

iMPACT still won't connect:

Welcome to iMPACT
iMPACT Version: 14.7
Project: /home/lukasz/VHDL/QLIW//auto_project.ipf created.
// *** BATCH CMD : setMode -bs
// *** BATCH CMD : setMode -bs
// *** BATCH CMD : setMode -bs
// *** BATCH CMD : setMode -bs
GUI --- Auto connect to cable...
// *** BATCH CMD : setCable -port auto
INFO:iMPACT - Digilent Plugin: Plugin Version: 2.4.4
INFO:iMPACT - Digilent Plugin: no JTAG device was found.
AutoDetecting cable. Please wait.
*** WARNING ***: When port is set to auto detect mode, cable speed is set to default 6 MHz regardless of explicit arguments supplied for setting the baud rates
PROGRESS_START - Starting Operation.
If you are using the Platform Cable USB, please refer to the USB Cable Installation Guide (UG344) to install the libusb package.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
File version of /opt/Xilinx/14.7/ISE_DS/ISE/bin/lin64/xusbdfwu.hex = 1030.
File version of /etc/hotplug/usb/xusbdfwu.fw/xusbdfwu.hex = 1030.
 WinDriver v10.31 Jungo (c) 1997 - 2011 Build Date: May 24 2011 x86_64 64bit 18:13:19.
Cable connection failed.
Connecting to cable (Parallel Port - parport0).
 WinDriver v10.31 Jungo (c) 1997 - 2011 Build Date: May 24 2011 x86_64 64bit 18:13:19.
Cable connection failed.
Connecting to cable (Parallel Port - parport1).
 WinDriver v10.31 Jungo (c) 1997 - 2011 Build Date: May 24 2011 x86_64 64bit 18:13:19.
Cable connection failed.
Connecting to cable (Parallel Port - parport2).
 WinDriver v10.31 Jungo (c) 1997 - 2011 Build Date: May 24 2011 x86_64 64bit 18:13:19.
Cable connection failed.
Connecting to cable (Parallel Port - parport3).
 WinDriver v10.31 Jungo (c) 1997 - 2011 Build Date: May 24 2011 x86_64 64bit 18:13:19.
Cable connection failed.
PROGRESS_END - End Operation.
Elapsed time =      2 sec.
Cable autodetection failed.
WARNING:iMPACT:923 - Can not find cable, check cable setup !

lsmod shows that modules are loaded:

[root@localhost ISE_DS]# lsmod
Module                  Size  Used by
windrvr6              193063  0 
windrvr6_usb           19502  1 windrvr6
(...)
xpc4drvr                8428  0 

 

Share this post


Link to post
Share on other sites
  • 0

I am only familiar with issues that Adept has with this board through Windows usage, so I am unable to really comment on how the drivers may/should behave with each other in a Linux environment. I have sent this issue to someone who is a bit more familiar with Linux than I am, so we will get back to you as soon as we have an update. Thanks for your patience!

Share this post


Link to post
Share on other sites
  • 0

I've gotten a response from one of our engineers about your question. 

"The programming solution on that board is actually Xilinx’s programming circuit. It’s very similar to the Xilinx Platform USB Cable, and the driver/software installation is the same as the procedure used to get the Platform USB Cable working. I’ve done this before but I don’t remember all of the steps. With newer Linux distributions the kernel drivers that Xilinx provides don’t work and you have to use their libusb based drivers. However, I believe it’s still necessary to install fxload as well as Xilinx’s UDEV rules.

Most of those files are located somewhere within the ISE installation directory." 

A couple links that were sent my way regarding this include this Xilinx support page and this user page. Hopefully these are useful to you. I'm still pretty green with Linux myself, however if these don't help resolve the issue I'll keep doing what I can to figure it out.

Edited by NAEastland

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this