• 0
Fabian123

Zybo-Z7-20 examples not working!

Question

Hello,

I have been working with Intel/Altera FPGA for several years now. I recently bought a Zybo-Z7-20 (July 2020)
because I am interested using the Zynq ARM+FPGA SoC for solving contemporary problems.

To get started, I tried to follow your instructions at
https://reference.digilentinc.com/reference/programmable-logic/zybo-z7/start

Unfortunately, I cannot get any Project running without errors in Vivado, Vitis or Petalinux.
Most of the given tcl scripts don't succeed to create Vivado project files, and even if this works,
I tried Vitis 2020 and event the hopelessly outdated 2017 and 2018 versions in the mainstream Ubuntu Linux 2020.04 LTS. Finally,
I ended up in installing 120 GB of different Vivado versions and lost a huge amount of time, which makes absolutely no sense to me!
This is very frustrating!

All the examples are hopelessly outdated (from the year 2017!!!) and not working any more.
Please Digilent, do your homework and give recent and working examples for the current Vivado/Vitis 2020 development environments
if you sell your high-priced products to your customers in 2020.
Since the Zynq 7000 is listed as supported with Vitis-AI, please give also Instructions for the Vitis-AI library for using the board for contemporary AI problems.

Best regards

Fabian

 

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi @Fabian123,

I'm sorry to hear you are not able to get the examples working as expected. Which specific projects were you attempting to get working? Most of our release projects on the Digilent GitHub from 2018.2 onwards do not use .tcl scripts to build the projects (.tcl scripts were used for earlier versions of Vivado). A number of our projects have been updated to 2020.1, though not formally released since the documentation is not complete yet (they are in the staging branches on our GitHub, https://github.com/digilent, rather than as a release)

I wouldn't necessarily say that 2017 and 2018 versions are hopelessly outdated; they just aren't the newest versions. Additionally, based on Xilinx's Release Notes Vivado 2020.1, Ubuntu 2020.04 LTS is not a formally supported OS; I'm not sure if this would contribute to any errors you are seeing though; that would be more of a question for Xilinx in terms of compatibility.

Let me know if you have any questions.

Thanks,
JColvin

Share this post


Link to post
Share on other sites
  • 0

Hello @JColvin,

thank you for your answer!

The examples are tried:

https://github.com/Digilent/Zybo-Z7-20-pcam-5c/tree/master
Working :), but with Vivado 2017.4 and 2019.1, but no Vitis 2020.1 version available.

Embedded Vision Demo
https://digilent.s3-us-west-2.amazonaws.com/resources/whitepapers/EmbeddedVisionDemo.pdf?_ga=2.93591453.1253467320.1595997339-1751738775.1593952945
Working :), but with Vivado 2017.4 only. No 2020.1 version available.

Petalinux-Zybo-Z2-20
https://github.com/Digilent/Petalinux-Zybo-Z7-20/releases
Only very old Vivado 2017.4 available.
Binaries installable but not booting rootfs on SD-Card.
Not working in Ubuntu 20.04.
Xilinx Petalinux  not working on Ubuntu 20.04.
Xilinx Petalinux Python version conflicts.
Xilinx Petalinux not installable as root with sudo to /opt.
Xilinx Petalinux not booting from SD-Card

Zybo-Z7-base-linux
https://github.com/Digilent/Zybo-Z7-20-base-linux
Only available for Vivado 2017.4 with TCL Scripts..., Not working.

 

Further Examples I tried:

Zybo-Z7-20-DMA
https://github.com/Digilent/Zybo-Z7-20-DMA/tree/master
Zybo-Z7-20-DMA: Vivado 2018.4 not installed on my system (already 120 GB occupied by vivado tools), Vitis 2020.1 not available.

Zybo-Z7-20-Pmod-VGA
https://github.com/Digilent/Zybo-Z7-20-Pmod-VGA/tree/master
Vivado 2018.2 not installed on my system, Vitis 2020.1 not available.

Zybo-Z7-20-XADC
https://github.com/Digilent/Zybo-Z7-20-XADC/tree/master
Stable tree is 2018.2, I did not see the development tree for 2020.1, I will try that soon...

I think the Xilinx way with resource exhausting, obfuscating, and version-incompatible development tools,
especially the tcl scripts is too complicated and error-prone compared to Intel Quartus...
What I also don't like is that Petalinux is very far away from vanilla Linux and
not installable as root user like every other Linux program.
If you try to install Petalinux, It takes a long time before it gives up with errors.

Another Question:
Is there any support for using Vitis AI on the Zybo Z7-20 available?

Best regards

Fabian

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now