• 0
bm0383

Zybo audio demo

Question

Hi,

im struggling with Zybo audio demo. I have this board https://reference.digilentinc.com/reference/programmable-logic/zybo/start , vivado 2019.1 and sdk 2019.1. I have downloaded this file https://reference.digilentinc.com/learn/programmable-logic/tutorials/zybo-dma-audio-demo/start, make project with vivado, updated IPs, create wrapper, make bitstream, export it to sdk. In SDK i made new project with hello world example and then copy audio files into src folder. Then i put fpga to board and run it, it runes without errors but i there was no sound from HPH. I changed Line out to hph out in code but still nothing. Then i just tried once again to create new bitstream in vivado and again exported it to sdk, and when i run it on board it stuck at recording.. just like dma wont send signal fDmaMM2SEvent. I erased the project and do it again and its still stucked at recording... I have tried a lot of project audio dma but none of them was working for me. It really confusing...

 

Thanks.

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hi @bm0383,

I apologize for the delay. I am taking a look into this since I am getting the same error when running the release version for the Zybo Z7-10 (which uses the same SoC) on Vivado/SDK 2018.2.

Thanks,
JColvin

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now