• 0
DigilentStudio

Mac Version Of Waveforms?

Question

5 answers to this question

Recommended Posts

  • 0

There is not currently a released version of Waveforms for Mac. Waveforms 3 will support Windows, Mac and Linux. We will be offering a public beta soon, I can't say exactly when.

Share this post


Link to post
Share on other sites
  • 0

Hi there

I've been using the Analog Discovery with a python code that I wrote that uses the waveforms SDK and it works just fine on windows. I've tried migrating to mac but I'm now having trouble with running my code. So far I followed the link above and installed Waveforms2015 and the Dilient Driver but when I run my code I get the error below ending with 'OSError: dlopen(libdwf.dylib, 6): image not found'

Can you advise? I think it because the install.sh (from the SDK folder) may not be installing correctly. In the terminal, when I run install.sh, all the lines say no such directory.

Error information:


runfile('/Users/Jason/Dropbox/JasonAnalogDiscovery/NMRspectrometer_redefiningAcquirePulseWaitandTrigPos.py', wdir='/Users/Jason/Dropbox/JasonAnalogDiscovery')
dar
Traceback (most recent call last):

  File "<ipython-input-165-c8d6aa72487a>", line 1, in <module>
    runfile('/Users/Jason/Dropbox/JasonAnalogDiscovery/NMRspectrometer_redefiningAcquirePulseWaitandTrigPos.py', wdir='/Users/Jason/Dropbox/JasonAnalogDiscovery')

  File "//anaconda/lib/python2.7/site-packages/spyderlib/widgets/externalshell/sitecustomize.py", line 685, in runfile
    execfile(filename, namespace)

  File "//anaconda/lib/python2.7/site-packages/spyderlib/widgets/externalshell/sitecustomize.py", line 78, in execfile
    builtins.execfile(filename, *where)

  File "/Users/Jason/Dropbox/JasonAnalogDiscovery/NMRspectrometer_redefiningAcquirePulseWaitandTrigPos.py", line 17, in <module>
    dwf = cdll.LoadLibrary("libdwf.dylib")

  File "//anaconda/lib/python2.7/ctypes/__init__.py", line 443, in LoadLibrary
    return self._dlltype(name)

  File "//anaconda/lib/python2.7/ctypes/__init__.py", line 365, in __init__
    self._handle = _dlopen(self._name, mode)

OSError: dlopen(libdwf.dylib, 6): image not found

Share this post


Link to post
Share on other sites
  • 0

Hi Jason,

This question will be better suited in a different part of our forum. I've taken the liberty of reposting it in the Scopes and Instruments subsection here.

Thanks,
JColvin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now