• 0
weetabixharry

Cmod S7 not detected by Vivado

Question

I have just received my new Cmod S7 module. Plugging it in to a USB3.0 port on my PC (Windows 7), it powers up and runs the out-of-box demo (lighting up the various LEDs in sequence).

However, I notice that Windows doesn't detect any USB device being connected. If I remember correctly, these FTDI chips are usually auto-detected in Windows. However, I don't get any notification, nothing appears in Device Manager, and a terminal emulator (Tera Term) can't see a serial port. In Vivado (2019.2), the hardware manager can't find any device to connect to.

I've tried a couple of USB cables (20cm - 30cm), which I believe are both fine, and also tried different USB ports on my PC.

What should I do?

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Never mind - I tried a third USB cable and everything suddenly works fine.

I think I read somewhere that the Cmod A7 modules are a bit sensitive on the USB interface, and I guess the S7 is cut from a similar cloth. Glad it's working now 😄

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now