• 0
TY Fan

Questions about using Pmod WiFi on a Zynq board

Question

Hi,

I'm trying to use Pmod WiFi on a Zynq board for a school project and it is required to add WiFi feature to the boards so that the mother board can send to the other boards. I built the basic block diagram but I'm not sure whether it works because when I run the template projects from Digilent/vivado-library on github, there is no response at the terminal, nothing happens. Does the board need a SD card for setting up a TCP/UDP echo server/client (there is already a SD card slot on my zynq board)? Also, can someone take a look at my block diagram to make sure it is correct?

Thanks, everyone.

590870793_2019-11-22(3).thumb.png.a384308ba3a5c2b861fe17256e7f3fb1.png

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hello @TY Fan,

Did you follow the Getting Started with Digilent Pmod IPs tutorial ?

I see that you are using Pmod Connector JE but the PmodWiFi IP's output is "Pmod_out_0".  I think it should be "je".

Also I read the README file of the example projects and there is no need for an SD card.

https://github.com/Digilent/vivado-library/tree/master/ip/Pmods/PmodWIFI_v1_0

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now