• 0

PYNQ-Z1 board don't boot anymore fro SD card



I have 3 pynq-Z1 board which I have used a year ago. When I tried to boot them again  this week all three board fail to boot from SD card. (The FPGA done LED doesn't even light up.) All used the standard SD cards ordered with the boards.  I tried to re-flash the Sd card with latest image, but the problem persists...  Swapped Sd cards from one board to another, but still no luck.... What could be the issue here?  All jumpers are in the right position. Board is powered by external power supply. Red led lights up. SD card content can be successfully read by PC...


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Please confirm the following:

  • Jumper JP4 is set to SD
  • You flashed the latest PYNQ-Z1 image from here.
    • How did you flash the image to the SD?


  • How are you powering the board? USB or External power supply?
  • Are your SD cards a high quality name brand or a no-name brand. We have come across inexpensive SD cards that can be used as storage but will not boot. They behave as if no card is inserted.
    • We recommend SanDisk Class 10
Link to post
Share on other sites
  • 0



1. Jumper is indeed set to SD position.

2. Power is external (using the Supply fro the PYNQ kit)

3. SD cards are the ones also supplied with the PYNQ Kit.  They are not Sandisk however.

All the board have booted with these SD cards before. all SD cards had original image. I tried one with a latest image. but no luck....

4. Yes, I waited for all boards at least 30 minutes to see if the done led got high and linux booted or even full night... 😉


It seems that after a few months of non usage, there is something that prohibits booting from SD card....


Kidn Regards,



Link to post
Share on other sites
  • 0

We just pulled a PYNQ from the shelf that hasn't been powered on in months also and it booted fine.

We powered the board over USB. Can you try that?

Do you see a new COM port in Device Manager in Windows when connecting a USB cable

Are TX and RX LED's flashing at all in the first minute after powering on?

Link to post
Share on other sites
  • 0

OK. Many things happened in the mean time.......

I ordered  DELKIN SDcards. Wrote image to them and they Immediately booted...

Then I used the 'bad' one from before and inserted into PYNQ board that just booted with a DELKIN card and it also booted now?????

Then I tried this 'bad' one again in PYNQ board that hasn't booted with DELKIN  and it did'nt work.

Then I re-wrote image to the 'Bad' one and it boots now in all boards (although slower...)

Then I tried my final image (not the PYNQ original one, but the one I need to operate the boards.. and It now also boots with both the 'DELKIN" and the 'bad' versions from before.....



1. after initial boot with NEW SD card one board stated booting also with 'old card'

2. after initial boot with NEW SD card another board didn't boot. It did however boot with the 'old' one from board 1.  I rewrote the image and now this also boots...

So issue might be a combination with SD card quality (although cards supplied with kit itself) and FSBL ?

Unfortunately now everything boots again... will switch on / off continiously to see if one will not boot again...



Edited by robbie
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now