• 0
cepwin

PCAM 5 demo app running but no image..

Question

I finally got the demo app to work but I am only getting light and shadows ...not an image... the screenshots are below.   There is no indication of an error but all I get is light passing through.   In other words, I can shine a flashlight at the camera and the light appears on the screen but I can't get any sort of image.   I've tried adjusting the lens to the point it got screwed off and it never focused on anything.  Could the camera be faulty? could the connection be faulty? is there some sort of issue with the code?  One thing I should add is that I was able to get the test pattern with the built in app so the HDMI is correctly connected. Please advise Thanks!!

 

Addendum:   I realized I had the lens cap on but once I took it off I still could not focus...it is still blurry lights and shadows

 

2026802120_Screenshotfrom2019-09-2815-44-22.thumb.png.159286ba4188a5b0f6ee4d114f416d9c.png

Screenshot from 2019-09-28 15-45-25.png

Screenshot from 2019-09-28 15-46-33.png

Edited by cepwin
additional info

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

It turns out I answered it myself....I was able to finally turn the focus by starting it with the lens cap on...once I started turning it and turned it a bit it slowly focused.   I was then able to see images quite well.  The key with getting the project to run is not letting it upgrade and simply doing the export and going into the SDK.  This leads to another question.....the example seems to rely on custom IP that Digilent provides. Is that correct?  If we're writing a new project does that mean the IP has to be updated?  Is the best bet to use HLS for any PCAM work?

Share this post


Link to post
Share on other sites
  • 0

Hi @cepwin,

This particular demo does utilize some IPs created by Digilent that we would need to upgrade to specific Vivado versions. I believe there is a plan to upgrade all of the Digilent projects in the upcoming months, though I do not know to what version they will be upgraded to.

I don't think you need to use HLS specifically, though I would probably recommend using SDK (I didn't create the Pcam project so I don't fully know the intricacies).

Thanks,
JColvin

Share this post


Link to post
Share on other sites
  • 0

Hi @cepwin,

I was actually referring to Xilinx SDK; it usually comes with the Vivado download unless you specifically exclude it. I don't think you would need Adept SDK in your situation.

Thanks,
JColvin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now