• 0
gentlemanJack

CMOD A7 Cable Problem, 5 Action Ideas - Please Comment

Question

 I have been trying to start my Cmod A7 today.  Ran into this cable driver problem.  Lots of discussions about it on the Diligent forums over maybe 3 or 4 years.  My Vivado is 2017.4, Windows 10 64-bit.  I went thru the "Getting Started with Vivado" tutorial, got the needed files, no problems with anything, generated a bitstream and …. when I tried to auto-connect with the Hardware Manager (by hitting "Open Target") It shows localhost(0) is Connected, but it also says:  'No hardware target is open' and "Program Device" in the Flow Navigator is still grayed-out.

And yes, I tried 4 different microUSB cables, including a 1 foot long.  My CmodA7 out of the box has the "DONE" light on, and the pushbuttons change the LED[2:0} indicating that the CmodA7 has a program already in it.

I read that some people install Adept 2.  I ran install_digilent.exe which I found under C:\XilinxFull\Vivado\2017.4\data\xicom\cable_drivers\nt64\digilent and it says I am up-to-date in a window that says "Digilent Adept Runtime Setup".

I also read about windrvr6.inf and xusbdrv.inf being a problem for Vivado Versions 2017.4 and 2018.2.  I see them under dlc10_win7 (which contains 18 files) but not under dlc10_vin10 (which only has 3 files)

I did run install_drivers_wrapper.bat as described in the forum: https://www.xilinx.com/support/answers/59128.html, running the cmd window as admin, moving the prompt to C:\Xilinx\Vivado\2017.4\data\xicom\cable_drivers\nt64
install_drivers_wrapper.bat C:\Xilinx\Vivado\2017.4\data\xicom\cable_drivers\nt64 c:\Xilinx\Vivado\2017.4\install.log c:\Xilinx\Vivado\2017.4\

... this is the log file results ......
NFO: InstallPath="C:\XilinxFull\Vivado\2017.4\data\xicom\cable_drivers\nt64\"
windrvr6 is not installed.
INFO: Installing Windows 10 pcusb driver...
Microsoft PnP Utility

Processing inf :            xpcwinusb.inf
Driver package added successfully.
Published name :            oem67.inf

Total attempted:              1
Number successfully imported: 1

INFO: INF file C:\Xilinx\Vivado\2017.4\data\xicom\cable_drivers\nt64\dlc10_win10\xpcwinusb.inf was successfully installed for driver.
INFO: Running digilent installer...

<<<<< Digilent Adept Runtime Setup >>>>>
Installer version: 1.4.6 release: 2015/12/08
Digilent Software Path: C:\Program Files (x86)\Digilent

Your system is up-to-date with the components of this installer.
INFO: Running SmartLynq installer...
INFO: SmartLynq installed successfully

.... So... going forward, should I:
(1) install latest Vivado (maintenance fee?)
(2) see why dlc10_win10 only has 3 files
(3) get a download of Adept 2 and use it to download the .bit file from Vivado
(4) put a large capacitor on the USB 5V Rail as described in https://forum.digilentinc.com/topic/4769-vivado-hardware-manager-disconnects-cmod-a7-target-in-win7/, Jan 10.
(5) call today a bad investiment and find another FPGA board
 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi,

purely as an idea: If you have the 35A-variant, you could try to run this (link below, use the latest link from the last posts).  You may need to install FTDI's standard driver, if not present.

It uploads a bitstream and exercises USB with regular traffic e.g. set ADC rate close to 1 MSPS and it'll use about 25 MBit/s. The application will immediately close with an error if USB fails.

There may be a virus warning e.g. with bitdefender which is to the best of my knowledge false.

 

Edited by xc6lx45

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now