• 0
chaitusvk

ZYBO BOARD NOT emitting packets when connected to switch

Question

I have implemented a small system with ZYBO-Z7 20 , It will send the switch status through Ethernet interface  .  Implemented with AXI GPIO and LWIP ,UNICAST ,BOARD HAS CONSTANT IP and REMOTE IP is CONSTANT.

  i am not using DNS

I am able to Send packets if Board is connected  directly to LAPTOP  and i am able to PING the Board from LAPTOP 

But when the Same setup when connected to Switch [allied telesis]  i am not able ping the board and no packets are flowing ...

Can any one help me where i have to look...

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

There may be a problem with the network switch. Have you tried a different switch?

Is the switch passing traffic for any other devices?

Have you tried pinging the laptop from the Zybo?

Are the IP's on the same subnet?

When connected to the switch:

  • Use tcpdump on the Zybo to see if any packets are going out or coming in.
  • Use Wireshark (if Windows) or tcpdump (if Linux) on the laptop to see if packets are going out or coming in.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now