• 0

LINX on the Raspberry Pi 2, 3 and 4 running Raspbian Buster


Question

Hi everyone,
LINX can be installed on the Raspberry Pi 4.

The LINX 3.0 Target Manual Install Process (https://www.labviewmakerhub.com/doku.php?id=learn:libraries:linx:misc:target-manual-install) did not work due to changes in the latest version of Raspbian.

Here is the procedure that I used to install LINX. The procedure also works on the Raspberry Pi 2B, Pi 3A+, Pi 3B and Pi 3B+ running Raspbian Buster.

1. Setup the Raspberry Pi using the latest Raspbian Buster Image.
2. Change the default password for the Pi account on the Raspberry Pi.
3. Setup a WiFi or Ethernet connection from the Raspberry Pi to your router.
4. Enable SSH on the Raspberry Pi.
5. SSH into the Raspberry Pi or open a terminal window on the Raspberry Pi desktop.
6. Check that the Raspberry Pi can access the Internet by entering the command

ping -c 4 raspberrypi.org

7. Enter the commands shown in bold below. 
Note: The text may wrap due to the web browser window size. I recommend copying the text into a text editor to see the original formatting. The commands are in the attached file linx_install_commands.txt

# Enable i2c and spi
sudo raspi-config nonint do_i2c 0
sudo raspi-config nonint do_spi 0
# Update Raspbian
sudo apt-get update
sudo apt-get dist-upgrade -y
# Install LINX
sudo sh -c 'echo "deb [trusted=yes] http://feeds.labviewmakerhub.com/debian/ binary/" >> /etc/apt/sources.list'
sudo apt-get update
sudo apt-get install -y lvrt-schroot
# Move the nisysserver.service and labview.service files to the systemctl folder
sudo mv /etc/systemd/system/multi-user.target.wants/nisysserver.service /lib/systemd/system
sudo mv /etc/systemd/system/multi-user.target.wants/labview.service /lib/systemd/system
# link liblinxdevice.so to the Raspberry PI device driver file liblinxdevice_rpi2.so
sudo schroot -c labview -d /usr/lib -- ln -s  liblinxdevice_rpi2.so liblinxdevice.so
# Enable the nisysserver.service and labview.service to start on boot
sudo systemctl enable nisysserver.service
sudo systemctl enable labview.service
# Start the nisysserver.service and labview.service
sudo systemctl start nisysserver.service
sudo systemctl start labview.service

You should now be able to connect to the Raspberry Pi from the LabVIEW Project Explorer.

Cheers,
Andy.
linx_install_commands.txt
 

Edited by andylb
Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hey just found your guide as i was having the exact same problem on RPi 4. Thank you so much! If i wanted to run a Project using AD2 on Boot, do i need to enable digilent runtime on boot as well?

Edited by jody
Extra question
Link to post
Share on other sites
  • 0

I have a Raspberry Pi 4 B running Rasbian BUSTER.

I attempted this procedure, but it failed when I entered the following commands:

sudo sh -c 'echo "deb [trusted=yes] http://feeds.labviewmakerhub.com/debian/ binary/" >> /etc/apt/sources.list'
sudo apt-get update

the following errors occur:

E: Conflicting values set for option Trusted regarding source http://feeds.labviewmakerhub.com/debian/ binary/
E: The list of sources could not be read.
 

I apologize for not being very familiar with Linux, but it seems that the issue was that it could not find the source list?

Any help would be appreciated.

Link to post
Share on other sites
  • 0

Thanks andylb🙂...

This worked perfectly, I appreciate all the headaches you saved me.  Only want to add 2 more items to your instructions:

1.  Before starting your list, I recommend typing  [sudo su].  Saves you from a security error that pops up somewheres around the "Install Linx" step.

2.  I am running Linx on [Raspberry Pi 4 Model B Rev 1.1] with the following OS [2020-02-13-raspbian-buster-full].

    The Raspberry Pi SoC (System on Chip) is a Broadcom BCM2835.  This requires modification of a certain Linx VI to make Linx work 

    with the Raspberry Pi 4b; otherwise you will get a [Unknown Device Error] when starting Linx.  See the following web page for 

    instructions:  https://www.labviewmakerhub.com/forums/viewtopic.php?f=12&t=3039&p=11915&hilit=+raspberrypi+4+os#p13542

          a) Open vi in Labview 2014:  

                       C:\Program Files (x86)\National Instruments\LabVIEW 2014\vi.lib\MakerHub\LINX\Private\Utilties\Get Device Type.vi

         b) Open the Block Diagram

         c)  Expand String Constant Array in front of [For Loop] by one row.  Enter the String BCM2835 into the new row cell.

         d) Add new Case to the Case Structure.  Insert BCM2835 for the Case.  Ensure the string constant "Raspberry Pi2 B" is passed

              out for this case.  (Note:  I think I tried passing out "Raspberry Pi4 B" but it caused an Error].

         e)  Save the vi and exit it.

3.  Start LINX:

         a) Start Labview 2014.

         b) At the [Create Project/Open Existing] window select Tools -> MakerHub -> LINX -> Select:  Linx Target Configuration

         c) Enter the Hostname - Username - Password and Click on Connect Target

          d)  After the other buttons activate click on Install Software.  When I did this the Installed Version and Available Version both said

                 14.1-11.  When I first clicked on  Launch Example after following the above instructions I got an error.  So I tried clicking on 

                  Re-Install and Version 14.1-11 was re-installed successfully.  After that I was able to Click on Launch Example and the

                  Example loaded successfully.   Disclaimer:  Since I don't have any hardware I cannot verify that the LED turned on and off. 

                  All I can state is that the software did not show any errors when I clicked on the LED button or Stop button.

 

 

            

    

Link to post
Share on other sites
  • 0
On 1/21/2020 at 5:32 AM, Orchitis said:

I have a Raspberry Pi 4 B running Rasbian BUSTER.

I attempted this procedure, but it failed when I entered the following commands:

sudo sh -c 'echo "deb [trusted=yes] http://feeds.labviewmakerhub.com/debian/ binary/" >> /etc/apt/sources.list'
sudo apt-get update

the following errors occur:

E: Conflicting values set for option Trusted regarding source http://feeds.labviewmakerhub.com/debian/ binary/
E: The list of sources could not be read.
 

I apologize for not being very familiar with Linux, but it seems that the issue was that it could not find the source list?

Any help would be appreciated.

i had the same problem, and this is how it is solved.

sudo nano /etc/apt/sources.list

modify the text file according to the attached picture. use control+x to exit. press y to confirm to save the file.

hope it helps!

 

-Hafiz

pi-linx3.jpg

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now