• 0
chainastole

Unable to connect to hardware target Arty Z7

Question

Posted (edited)

This request for help is duplicated at Xilinx forum.

I started working with Xilinx Arty Z7-20 development board with Vivado 2019.1. I fail to open hardware target. The localhost is seen to be connected but Hardware Manager is said to be unconnected and after refreshing server I get the following:

refresh_hw_server {localhost:3121}

WARNING: [Labtoolstcl 44-27] No hardware targets exist on the server [localhost:3121]

Check to make sure the cable targets connected to this machine are properly connected

and powered up, then use the refresh_hw_server command to re-register the hardware targets.

1.      I tried both “QSPI” and “JTAG” settings of JP4 jumper. In wain.

2.      I learned from Xilinx and Digilent forums the possible culprit is poor cables drivers installation. I remember I included the cables drivers during initial installation.

3.      I re-ran Vivado update without uninstall and included cable drivers again (checked their respective checkbox). But after second trial I saw they are again proposed to be installed – their checkbox is still unchecked. The hardware target wasn’t opened.

4.      I followed the instructions in https://www.xilinx.com/support/answers/59128.html. I ran the cables driver installation batch file as administrator in Windows and it seemed to success. Log is attached. But in wain. The hardware target wasn’t opened.

5. Need to emphasize the cable I use to power up the board and to program it is the plainly usual USB A to micro B, wihch I connect to USB port of the board. From reading the Vivado programing and debugging ug908 document it could built up an impression that special supported JTAG cables are needed. But it would be too strange - the Arty Z7 board manual doesn't mention any need in a special cable and Digilent specifies this cable functionality is already built in into their boards.

Please, help.

install_drivers_wrapper.log

Edited by chainastole

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

It appears there are 2 types of USB cables - with data and power only. The simplest method to determine the type is to connect mobile to computer. If seen, it is data cable. Appeared my USB cable was of power only type. Luckily I had a data type in my home stock too and after connection the problem resolved. Lucky for me because my ToDo list included:

1) Wait for replies on forums;

2) Re-install Vivado;

3) Try on my work environment;

4) Use mini-SD instead;

5) Try to power with separate power cable;

6) Try another computer after installing Vivado on it;

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now