• 0
k16blfurm

Scripting Runtime in Ubuntu with Adept 2 runtime

Question

Hey everyone,

I'm probably missing something really simple but I was wondering why I get this issue while trying to read a certain section of flash memory. Thanks in advance!

$ dsumecfg read -d CmodS6 -s 1 -f section1.bin
ERROR: invalid number of devices found in scan chain: 1
ERROR: failed to configure FPGA

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hi @k16blfurm,

It looks like you are trying to read from the flash of a Cmod S6 using the dsumecfg function. I believe that Dsumecfg is used with the NETFPGA Sume as described in the the reference manual for the NETFPGA SumeHere is a forum thread on how to program the flash on the Cmod S6 using iMPACT.  Adept 2 only configures the Flash on a couple of the Digilent FPGA's. i do not believe that Adept 2 configures the FLASH on the Cmod S6 as shown in the screen shot of the Adept 2 GUI.  Here is a xilinx thread that discusses programming FLASH from the command line using iMPACT.  Here is a non-digilent tutorial on using Adept in the command line that might be helpful as well.

best regards,

Jon

image.png

Share this post


Link to post
Share on other sites
  • 0

K, actually I'm still getting that error even after I initialize it. I was wondering if you have any more run time guides I could use.

 

Thanks,

- Blaine

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now