• 0
alien18331

Zedboard Vivado SDK Hello World Outputs Nothing to Terminal

Question

I'm using Vivado 2019 and a Zedboard, trying to implement "HelloWorld" in PS and output "Hello World" at PC terminal.but it doesn't work.

usb-uart and usb-jtag is connected with PC (Win10)

i'm using mio-46,47 to uart0

please help me...

image.png.b5d31d470d7ecb65c2c8bb3e19c21fa9.png

 

my step:

1. vivado open block design > HDL wrapper

image.png.acca8175c13971b3f0012898770b0382.png

2. run implementation

3.Export Hardware

4. launch SDK > new application project

5. open putty for monitor (COM4, speed is 115200)

6. SDK run configuration and the setting as following > Run

image.thumb.png.e2e12e0393ce588adf9f7afdfbe0ba1f.png

image.png.a02961a08a1696ff15641f0acdc0fa97.png

7. run result as following

image.png.5da8d054f0a006c8e73edfd50f693b2a.pngimage.png.322b2ead8c7e0199a49acc67ed56a377.png

8. the com port terminal is nothing...

image.png.b5d31d470d7ecb65c2c8bb3e19c21fa9.png

 

please let me know where i do the wrong step..

thank you very much.!!!

 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hi @alien18331,

Welcome to the Digilent Forum!

I would suggest to use/install the Digilent board file.  The board files become the default setting when running block automation. After running block automation connect  m_axi_gp0_aclk pin to the fclk_clk0 pin. I have attached screen shots of the process for getting the hello world project working. 

best regards,

Jon

 

image.png

image.png

image.png

image.png

image.png

image.png

image.png

image.png

image.png

image.png

image.png

image.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now