• 0
HItesh

Problem with CMOD A7

Question

I'm also facing the same problem with USB. I am using the same USB cable for  Nexys4 DDR as well, it works perfectly but with CMOD A7, sometime it works and sometime it doesn't. What is the solution?? Please help. 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

This board is fairly demanding when it comes to cables. It's very common with FPGA boards that some cable works with device x but not device y (there are many low-quality cables on the market and they fail gradually). I'd suggest to get a new, quality one.

It seems cheap advice but if the cable is the root cause, it needs to be fixed there.

Share this post


Link to post
Share on other sites
  • 0

We have found that a 100nF capacitor attached across VBUS and ground near the connector makes the Cmod A7 more tolerant of out of spec cables and we will consider adding it to a future revision.

There aren’t any pads for the capacitor, which makes it a bit challenging to solder in a 10V, 100nF ceramic capacitor. We managed to stack it on top of half of D1 and half of C65, which are both on the bottom of the board.

image.png

When testing with USB.org certified cables, we haven't been able to reproduce any connectivity issues.

We also recommend plugging in the cable into a port directly on the motherboard or into a USB hub instead of a front panel USB port.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now