• 0
sreehari

Arty Board unable to receive response from Ethernet PHY

Question

Hi,

 I am able to run ethernetlite example code (internal loopback) available in Xilinx SDK. Hardware platform I used was echo server one.

I tried to do a simple mdio read to read the PHY registers using following function 

XEmacLite_PhyRead () , Physical address set as 1... Using scope i probed mdio line (R173) and i could see activity for the initial write but when the read section line remains high....Thus returning 0xffffh.... 

PHY reset is held high (R183)

I tried scanning the entire address range available for PHY but no response. Every time the register content is the same  0xffffh.

/****

for(reg_count=0;reg_count<32;reg_count++)
{
    Status=XEmacLite_PhyRead (EmacLiteInstPtr,reg_count,3,&RegContent);
    if (Status != XST_SUCCESS) {
        return XST_FAILURE;
    }
    if(RegContent!=0xffff)
    {
        break;
    }

******/

Why does my PHY not respond to MDIO commands??.... Am I missing something...please Help

 

Edited by sreehari

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi @sreehari,

Welcome to the Digilent Forums!

As of yet I haven't used the LWiP with MDIO commands. Here is a forum thread that discusses MDIO with the Arty ethernet using linux and Here is a non-digilent forum thread that might be helpful.

best regards,

Jon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now