• 0

Xilinx VCU-118 And Digilent USB-2-JTAG IC failure


Hi everyone, 

I've experienced some issues using the Xilinx VCU-118 FPGA, along with Digilent USB-2-JTAG IC . (the USB 2 JTAG is embedded onto the FPGA board.)

Basically, this issue occurs on two of the 5 boards we use, and it seems like the board isn't being recognized by vivado Lab (ver. 2018.1) upon USB connection to my PC.

To be more specific, the problem is that upon connecting my VCU118 FPGA board to my PC (WIN7, using USB cable to the board JTAG port) and launching vivado's hw server, it doesn't recognize the board. I get the following error message:

[Labtoolstcl 44-27] No hardware targets exist on the server [localhost:3121] Check to make sure the cable targets connected to this machine are properly connected and powered up, then use the refresh_hw_server command to re-register the hardware targets.


Iv'e opened a thread over at Xilinx support forums at first, https://forums.xilinx.com/t5/Evaluation-Boards/VCU118-FPGA-is-not-recognized-by-vivado-hw-server/m-p/949578#M21119

thinking the board might be acting up,  However, by programming the FPGA board using Xilinx platform cable (Connected directly to JTAG, bypassing the Digilent USB 2 JTAG IC) we were able to show that it's probably a failure of the USB to JTAG IC. 

Upon further investigation, we figured that something might be wrong with the FTDI chip on the USB-2-JTAG IC. So we read the FTDI chip's content using FTprog utility. This is a comparison between the boards that does work, to the faulty one:

[good - show Manufacturer , details, etc. ]


[ Bad one - seems blank ] 



Is this really whats wrong? Is there a way to "program" the FTDI chip with valid data? 

I tried to install the latest drivers provided with vivado. Perhaps a newer version exists?

Thanks for the help,





Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hi @AThomas,

Which JTAG IC are you using? We at Digilent also like to keep track of the usage of the JTAG reprogramming application (and as the application re-flashes the chip, it's easy to ruin a number of devices unitentionally, much like how our JTAG devices become unrecognized in the first place).


Link to post
Share on other sites
  • 0

Hi everyone,

I am facing the same problem with my VC U118 board. I did contact xilinx people for solution and they redirected me here for solution.

 @JColvin would you mind to PM the instructions to reprogram the flash.

I have tried using the FT_PROG utility with all settings to the default values. Image2 is for working board and it detected the FTDI device and the image1 is for non working board which doesn't detect the FTDI device. Thanks in advance for helping.


NOTE: the FT232H device type is set manually while working with fault board and that's why device type is visible in image1.





Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now