• 0
Sign in to follow this  
SeanS

Genesys 2 LwIP echo_server project creation

Question

Posted (edited)

Hello, I was following the instructions here https://reference.digilentinc.com/learn/programmable-logic/tutorials/genesys-2-getting-started-with-microblaze-servers/start

to build the echo_server example project, but project creation failed in step 11 with the following SDK Log:
 

Quote

 

09:01:57 INFO : Registering command handlers for SDK TCF services

09:01:57 INFO : Launching XSCT server: xsct.bat -interactive C:\ROIC_FPGA3\OOB\OOB.sdk\temp_xsdb_launch_script.tcl

09:01:57 INFO : XSCT server has started successfully.

09:01:58 INFO : Processing command line option -hwspec C:/ROIC_FPGA3/OOB/OOB.sdk/system_wrapper.hdf.

09:01:58 INFO : Successfully done setting XSCT server connection channel

09:01:58 INFO : Successfully done setting SDK workspace

09:02:56 ERROR : (XSDB Server)ERROR: [Hsi 55-1545] Problem running tcl command ::sw_intc_v3_7::generate : can't read "source_name(12

09:02:56 ERROR : (XSDB Server))": no such element in array

while executing

"string compare -nocase $source_name($i) "system""

("foreach" body line 18)

invoked from within

"foreach periph $periphs {

#update global array of Interrupt sources for this periph

intc_update_source_array $periph

lappend ..."

(procedure "xredefine_intc" line 21)

invoked from within

"xredefine_intc $drv_handle $file_handle"

(procedure "xdefine_canonical_xpars" line 72)

invoked from within

"xdefine_canonical_xpars $drv_handle "xparameters.h" "Intc" "DEVICE_ID" "C_BASEADDR" "C_HIGHADDR" "C_KIND_OF_INTR" "C_HAS_FAST" "C_IVAR_RESET_VALUE" "C..."

(procedure "::sw_intc_v3_7::generate" line 57)

invoked from within

"::sw_intc_v3_7::generate microblaze_0_axi_intc"

09:02:56 ERROR : (XSDB Server)ERROR: [Hsi 55-1442] Error(s) while running TCL procedure generate()

ERROR: [Hsi 55-1450] Error: running generate_bsp.

09:02:59 ERROR : Error generating bsp sources: Failed in generating sources

 

 

I am running Vivado 2018.2 and have upgraded all IP to their most recent versions.

In Vivado, I have tried deleting the microblaze_0_axi_intc interrupt controller and re-instantiating it, making sure to have Vivado Auto-assign the address, but once I try creating the project again in SDK the same error gets thrown.

Any ideas what could be causing the error?

-Sean

Edited by SeanS
additional information

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this