• 0

Petalinux in Cora z7 not finding RTC


Go to solution Solved by Ionel,

Question

Hello everyone!

I'm trying to install Petalinux on a Cora Z7-10 I followed all the steps described here: github.com/Digilent/Petalinux-Cora-Z7-10 but when I try to boot it I get this message:

hwclock: can't open '/dev/misc/rtc': no such file or directory

after this, I can't write anything in Minicom.

As in my folder /dev didn't have the misc folder, following some advice that I found on the net I created the folder and first tried to soft-link /dev/rtc0 and then hard-link it also but none of those worked, I still get the same error.

Did anyone go through the same issue or has any idea to solve it?

Thanks you very much in advance.

coraz7.png

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 1
  • Solution

Hello @gmodia

Please try picocom: $ sudo picocom -b 115200 /dev/ttyUSB1

Note: this will work only after the device is powered on and the device /dev/ttyUSB1 is provided by your machine kernel. You could watch when that happens in a second terminal window by issuing: dmesg -w

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now