• 0

Pmod WiFi with TCP server and client demo not working



I am having trouble to setup the Zedboard Pmod WiFi communication. I used the TCP server and client demo, but two zedboards couldn't find each other. If I enable my Desktop WPA2, both server and client were able to find it. I wonder there is anything not mentioned in the github instruction. Additionally, once I tried to switch WPA2 to WEP40 or WEP140, there are errors while building the project in SDK:

'keySet' was not declared in this scope   
'WEP40KEY' in 'class DEWFcK' does not name a type 


But keyset has been defined in the header. Any advice?


Share this post

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 1

Hi @conanandai100,

We responded to your other post here

1) Have you tried using the WIFI variant client/server projects?

2) Are you still experiencing the same issues?

best regards,




Share this post

Link to post
Share on other sites
  • 0

Hi @jpeyron

Thank you for the reply. I thought I used the WiFi variant client/server code in the TCPEchoServer/TCPEchoClient folder under the Diligent WiFi github. Do I make a mistake by copying the wrong one? I just cannot tell the difference between the wired variant and WiFi version from the code/readme file.

Yes, I still have the issue unsolved. Since I replied the other post, this post can be closed. Sorry for the multiple posts as I didn't get the reply of the other at that moment.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now