• 0
Jzal

New and already need help, Pmod MTDs Arduino

Question

Hello,

I'm new here, and really need your helps and advices. I tried to use the Pmod MTDs on arduino but other than the backlight, nothing reacted. I connected the Pmod MTDs directly to the arduino using simple wire, like this:

V--> 3,3V

G--> GND

Pin 4 --> Pin 13

Pin 3 --> 12

Pin --> Pin 11

I'm not sure about this, so if anyone can show me how it's done I would really appreciate it.

For the code I used the demo of the library given.

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Hi @Jzal,

Welcome to the Digilent forums!

Here is the resource center for the Pmod MTDS. The Arduino code is available on the  Multi-Touch Display System (MTDS) Firmwar. In the \MTDS\Documentation folder there is a QuickStart text file that explains in more detail how to use the Pmod MTDS with an arduino using Arduino IDE.

Please attach screen shots of the errors you are getting in the Arduino IDE.

best regards,

Jon 

Share this post


Link to post
Share on other sites
  • 0

Hi @Jzal,

The Pmod MTDS has a logic level of 3.3v. You are powering the Pmod MTDS correctly using the 3.3V rail on the Arduino. The SPI pins need to be also at 3.3V which is not the case on the arduino spi pins. You will need to use a level shifter like the Pmod LVLSHFT.

best regards,

Jon

Share this post


Link to post
Share on other sites
  • 0
On 5/3/2019 at 9:43 AM, Jzal said:

I see, thanks for your help. I'll try to get a Pmod LVLSHFT then.

I got Pmod LVLSHFT, but I still can't make my Pmod MTDS work on arduino. Only the backlight is working. So can someone show or explain to me the wiring I should do ?

Share this post


Link to post
Share on other sites
  • 0

Hi @Jzal,

We should have some bandwidth to get the pmod MTDS working with the Arduino later today or early next week.

While in the interim do you have an sd card installed into the Pmod MTDS with the appropriate files load?

best regards,

Jon

Share this post


Link to post
Share on other sites
  • 0

Hi @Jzal,

Glad to hear you were able to get the Pmod MTDS working. Thank you for sharing what you you did.

best regards,

Jon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now