• 0
hmd

Installing Cable Drivers and Board Files

Question

Posted (edited)

I am running Vivado 18.3 on Ubuntu 18.04, and cannot connect to my Arty board. While troubleshooting, I found directions on installing cable drivers and board files (https://reference.digilentinc.com/vivado/installing-vivado/start), however I cannot find the path referenced in 2.1. I have an /opt directory, but it is empty, and while I can find a couple /data directories that look like they could be correct, none of them contain a xicom (or .xicom) directory.

Note: I installed Vivado a while back but never got around to playing with the board until now. I wanted to exhaust all options before trying a fresh install of Vivado.

SOLUTION UPDATE: I found the correct directory path by typing "which vivado" into the terminal, which pointed me to /tools/Xilinx/Vivado instead of /opt/Xilinx/Vivado

Edited by hmd
added solution

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Hi @hmd,

1) Did you install Vivado 2018.3 on a different drive?

2) Was vivado 2018.3 installed at the default path?

3) Please attach a screen shot of the command  " ls -l "  when in the home/  and the  opt/   directory. Also make sure that you are root.  

best regards,

Jon

Share this post


Link to post
Share on other sites
  • 0

Thanks for such a quick response!

1 hour ago, jpeyron said:

1) Did you install Vivado 2018.3 on a different drive?

No

Quote

2) Was vivado 2018.3 installed at the default path?

I thought I had, but I installed it in the home directory, and everything I'm reading now says the /opt directory is default. I installed a couple months ago.

Quote

3) Please attach a screen shot of the command  " ls -l "  when in the home/  and the  opt/   directory. Also make sure that you are root.  

home_opt.png.39c80772ae5c36d84a496eb2c7e5c9d2.png

Currently, I'm leaning towards uninstalling Vivado and reinstalling in the default directory, so if you don't see an obvious solution here don't spend too much time on it. Thanks!

Share this post


Link to post
Share on other sites
  • 0

Hi @hmd,

Change directory(CD)  to the root directory and run the command s -l there.  Its been a little bit since I have played around with Linux in my Virtual machine. I believe the OPT directory is there. Sorry about the mis-information.

best regards,

Jon

Share this post


Link to post
Share on other sites
  • 0

Hi @hmd,

I opened my VM and looked opt/ from the root directory. It has the Xilinx/ directory. I think it would be best to uninstall and re-install Vivado an leave it to default settings. Make sure that you are root while installing Vivado to insure there is no issues with permissions.

best regards,

Jon

Vivado_linux_path.jpg

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

I was poking around and seem to have found a solution, the correct path for me starts with /tools, not /opt. I found this by typing "which vivado" into the terminal (not sure why I didn't think to try that sooner). Once I found that I was able to complete the installation, and can now connect to the board. Thanks for the help!

Edited by hmd

Share this post


Link to post
Share on other sites
  • 0

Hi @hmd,

I'm glad to hear that the command which vivado helped you find the path needed to complete the installation. Thank you for sharing what you did.

best regards,

Jon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now