• 0
birca123

Running VTC self test freezes on ZYBO

Question

Posted (edited)

Hello,

My application freezes after I run the self-test for a video timing controller. What is the cause of the problem? 

The used Block design is shown below.

Best regards,

Toni

Capture.JPG

Edited by birca123

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hi @birca123,

The AXI bus may be waiting for the peripheral to respond (by acknowledging the write) and it isn't.

This can be caused by a variety of things, but having the addresses wrong would be one to check. Can you add an ILA module and see what bus transactions are taking place?

Here  is a xilinx forum thread about possible timing issues from the video timing controller.

best regards,

Jon

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Hi @jpeyron,

Sorry for the late response, I'm busy these days. 
The problem is that I've never used ILA modules before and it would take time for me to understand it. Can you check it real quick?  The project files are available on the following link: https://www.dropbox.com/s/tjd21flsmxn650i/ZYNN_project.rar?dl=0

I appreciate your help, best regards.

Toni

Edited by birca123

Share this post


Link to post
Share on other sites
  • 0

Hi @birca123,

I reached out to one of my co-workers which happens to be currently having a similar issue with the Video Timing Controller on their project. We will be looking into this further but currently havent found a cause. We also would suggest to reach out to Xilinx about the Video Timing Controller hanging as well.

best regards,

Jon

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now