Recommended Posts

Further to my struggles here https://forum.digilentinc.com/topic/17957-open-logger-some-basic-doubts/?tab=comments#comment-46282   I must say today was a lucky day ...

Yes the OpenLoggerMZ worked as it should with another laptop running WINDOWS 8.1. Using this opp i even upgraded the firmware to 0.1719.0 and all well.  Could feed the Wavegen output to CH1 and could see the plot. Atleast the board is still not bricked ... whew !! 

Then try the same with WINDOWS 10 which is my own laptop.  Nothing works . Board connects only in offline mode and even then reports OpenScopeMZ ( see the mess in the reporting .. OSMZ and bottom line reads OpenLoggerMZ) and of course nothing more happens.  

So its confirmed that this board is not working with WIN10. I even tried to invoke compatibility mode with WIN8.1. No luck  

 

 

Capture.JPG

Share this post


Link to post
Share on other sites

Hi @Raghunathan,

Can you share information in regards to your WIN10 machine, such as hardware spec, OS patch versions, etc? I run WIN10 myself and have been successful in working with the OpenLogger and WaveForms Live in this environment. There's another factor at play that is causing the malfunction you are seeing, and I'd like us to get to the bottom of the issue.

Can you also check to see what the version your local copy of WaveForms Live is? If you visit the settings panel, in the bottom left of the page you'll see WaveForms Live <version #>. It is possible that your local copy is an older version of WaveForms Live that doesn't support the OpenLogger. If it is an older version, you can visit the WaveForms Live wiki and download the offline build (this link will download the latest build). Then, once you've got that downloaded, you need to extract that zip to where the Agent will serve the files from, located at C:\Users\<username>\AppData\Local\Digilent\Digilent Agent\www.

If you visit the http://127.0.0.1:42135/ address, check the version again. If it looks like the page hasn't updated, you should do a hard refresh, as your browser probably cached the old files. This can be done with a Ctrl+Shift+R.

Let me know how that works out, and what your WIN10 machine info are.
AndrewHolzer

Share this post


Link to post
Share on other sites

Sure Andrew... I will help you as much as I can. As a LabVIEW programmer for more than decade, I know Digilent very well and I am sure they dont publish buggy SW. I only need to latch on to the offending part ...

The local copy of WindowsLive is 1.3.0.  I have downloaded the latest but see its only 1.4.5 whereas the the live on on the web is 1.4.8. For sure I will try to swap the local copy as you guided. 

Attaching the details of my PC.

Window10_Detail.JPG

Share this post


Link to post
Share on other sites

Good news !!

OK the Waveforms Live version 1.4.10 works in local mode on a WIN10 laptop. But I don't think it launches with the last saved profile... will be a big advantage if it does. Now every time I have to choose the saved profile. ( or am I expecting way too much ??) 

Even now for some odd reason,  the on line version does not work .... it launches but fails to connect when I click ADD. Ctrl+Shift+R relaunches but still does not help.

So i first disconnect WiFi by choosing Airplane mode and force the Agent to connect to the local copy. I know it sounds pretty funny but that is the fact.

Per se this is better than the previous instance where i could not connect in any mode on a WIN10 machine.

Now I will have to check the SD card logging ... who said life is boring ?!🤣

Share this post


Link to post
Share on other sites

I'm glad to hear that you've made some progress, Raghunathan, and I greatly appreciate your patience.

Nothing about your system tells me it would be interfering with the agent, so I need you to do some more digging for me. I'd like to see what the console output is when you try to add your OpenLogger. Before doing anything, visit the Settings page, and click Advanced. Click the Change Console Log button, and choose Console. Once you've done so, press Ctrl+Shift+i to open the Chrome Developer Tools, and make sure the Console tab is active.

Run through adding the device until it fails again. You should see a bit more detailed information as to why it is failing in the Chrome Developer console. If you can share that with me as a screenshot or some other way, I would appreciate it.

About the profile: You shouldn't have to select the last saved profile when launching WaveForms Live. Ideally WaveForms Live recognizes what profile your device has assigned to it and will load it up, but that doesn't seem to be working. If you could also give me the console output after entering the logger page (when WFL checks the device profile) and share that, we should get to the bottom of this issue as well.

Thank you for your cooperation and patience,
AndrewHolzer

Share this post


Link to post
Share on other sites
Posted (edited)

Followed your instructions and was able to obtain a screen shot of the failed connect process. Attaching it herewith .. Please let me know the next step. And just FYI, even now if I disable WiFi on my laptop, I can connect to the Localhost: 42315 server.  Of course it uses the default profile for this. 

 

Console.JPG

Edited by Raghunathan

Share this post


Link to post
Share on other sites

Hey @Raghunathan,

Thank you for the screenshot here. What I am gathering from this image and your previous posts is that you are possibly running into a network priority issue. There are several things we can do here to see if this is truly the case.

A network priority issue may arise when you are connected to multiple networks, say over ethernet and WiFi, or when you are running VPN software. When your machine sends data over the network, it needs to decide which interface it uses first, and this priority is usually established within the OS. 

So, first: Is your WIN10 machine connected to multiple networks and/or is it running any VPN software?
If this is the case, then you may need to reorder the priority within Windows to fix the issue. This guide shows you how to change the interface metric which will affect the interface priority level.

If you've tried the above solution to no avail, or it doesn't apply to you then we'll try something else. WFL normally uses the localhost address on port 42135 to communicate with the agent, and I'd like you to try and see if we can use localhost at all. So, secondly, I want you to open your CMD prompt, and enter ping localhost. You should see some output saying 'Pinging <machine-name> with 32 bytes of data' followed by several replies. If you don't see any of those replies then something is blocking you from localhost.

If you are blocked from localhost, when connecting to the agent you can replace where it says localhost with 127.0.0.1. This is the IPv4 address of localhost, and WFL should work as if you had localhost and if your problem doesn't persist.

If these steps don't fix your issue then there is something else that is giving you trouble. In that case, we'll continue to dig further and see what we can come up with.

Let me know if you are running any VPN software or are connected to multiple networks, as well as whether the ping localhost works for you or if using 127.0.0.1 works as well.

Regards,
AndrewHolzer

Share this post


Link to post
Share on other sites

@AndrewHolzer

Could carry all your instructions :

1. I am not running any VPN. 

2. Work exclusively with WiFi only and no cable is plugged into the RJ45 Ethernet port.  Yet went ahead and set the priority metrics for WiFi as 1 and Ethernet as 2. 

3. Localhost pings fine with no issues. 

4. Attaching the console out after doing above. Now I got a message saying No Response. ( In this i see a large chunk of warning in red. ) 

5. As ever, could connect after I invoked the Airplane mode but of course only on default profile settings. 

Waiting for your further instructions. If its working with so many other people it should for me also !! Thanks for your time. 

Raghu

No Response details.JPG

Share this post


Link to post
Share on other sites

@Raghunathan,

Let's try a few more things here. First, can you remove the OpenLogger you have added there, and try adding it again while still on the network? What I'd like you to do differently is replace localhost with 127.0.0.1 when you are at the step where WFL requests the URL for the Agent.

Are you running any anti-virus software on your machine? I don't expect it to be causing you any issue (and see no reason why turning on Airplane mode would affect it) but it's still a possibility. If you are running anti-virus, turn it off for a moment and try adding the device again.

Another thing to try is to connect the OpenLogger to your WIN8.1 machine and run the Agent there, but use WFL on your WIN10 machine. When you go to add the Agent, replace localhost with the IP address of your WIN8.1 machine. Even if this works its still not an ideal setup. I'm asking you to try this so that I can get a better feel as to what the real issue is here.

If you try all that and it still doesn't work, then I'd like you to try a new build of the Agent. You can download that here.

Let me know what your results are. I will continue to research this issue and get to the bottom of it all.

I personally appreciate your patience as we work through this issue,
AndrewHolzer

 

Share this post


Link to post
Share on other sites

@AndrewHolzer

1. Tried to change the localhost to  127.0.0.1:42315  with the On Line version of WaveForm Live.  No luck. 

2. Could not carry out the check with the WIN8.1 machine on network as that engineer is on leave. 

3. Installed a new copy of the Digilent Agent ( 1.2.4) and checked. The screen shot is attached. 

4. Antivirus .... I run the native Windows Defender and have enabled pass through Firewall. See attachment. But I see two copies of Digilent Agent ? I am sure I uninstalled the old version before installing the latest. 

 

If you see the Chrome screen shot , you will see it is saying " Insecure" in the address bar. Is this the reason it cannot connect with Agent ? 

Digilent Permissions.JPG

DigilentError.png

Share this post


Link to post
Share on other sites

Apologies for the delay @Raghunathan.

Can you please take a look at the task manager and check to see if there are multiple versions of the Agent running? Even if you don't, I suggest that you use the task manager to kill any running Agent processes, then make sure that you start the latest version only, then try connecting.

As another test to see if your browser can hit the agent, if you visit http://localhost:42135/debug in your browser, with airplane mode off, you should see a page that says "Debug Controller Page...".

If you get the chance to hit a WIN8.1 machine from your WIN10 machine, I'd like to see the results of that test as well, but no worries if this can't be done.

AndrewHolzer

Share this post


Link to post
Share on other sites

Hi Andrew

I just tuned out for some weeks to see if there are any updates posted in the interim. And whether that will help my now  Openlogger that is not Win10 friendly. But still the same status. I see that there is a new firmware 0.1807 but of course that never updates as it fails in the end. And I try to do a raw update without bootloader but for that the Web page is still only the 0.1719 version.  You cannot win either way !! 

I have checked Task Manager and only one version of the Agent is running ( Version 1.4)  and I am able to see a page " Debug Controller page …" 

And that's it …. no logging to SD card .... no WiFi. The board is idling happily. 

Actually I feel bad in posting only problems here.. as I am sure such a product would have passed rigorous testing. Maybe I am stuck with a dud piece. 

Share this post


Link to post
Share on other sites

Hi @Raghunathan,

I've had a chance to try replicating your issue on several WIN10 machines, but haven't been successful. This leads me to believe that there is something about your machine that is causing the issue. Without troubleshooting your system, all I can say is use a WIN8.1 machine.

Regards,
AndrewHolzer

Share this post


Link to post
Share on other sites

Hello Andrew,

Going by your first sentence I gather its working fine on WIN10 machines.  And that also means the piece i got has a hardware bug.... all our various efforts so far were with the basic ASSUMPTION that  the OpenLogger I have is perfect. With no way to return I guess I will need to buy one more as the functionalities that it has are the exact ones required by me and I cannot change all my laptops to WIN8.1.  Now I am not sure of the delivery times ...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now