• 0
CaptIgmu

Vivado 2018.3 can't find Digilent board files

Question

I just purchased the Arty A7 board and have been following along with the tutorials and installed Vivado 2018.3 WebPACK on Ubuntu 18.04 LTS . I also set up the cable drivers, Digilent boards from github and  the Vivado_init.tcl for startup. Alas, Vivado defaults to Xilinx development boards and I can't pick my Arty-A7 board (not on the list). Even if I put the board file directly in  . . ./data/boards/board_files as per the instructions, Vivado can't find it. I have tried changing file permissions, renaming files, moving files to different folders and even tried to "sneak" the arty_a7_35 files into the existing ac701 folder to no avail. Made no difference with or without a license and Digilent clearly states in the docs: "Most people don't need a license." Looking at the Digilent and Xilinx forums, this inability to recognize the Digilent board files in Vivado is a recurring theme with some solving it and others . . . not! The saving grace is that the Hardware Manager sees my board, I just can't use it yet. I would appreciate any help so I can get started with this very interesting board.

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
Posted (edited)

Vivado is pretty picky about having the correct folder structure. 

On my Centos system, the path to the Arty board files and the contents of the folder looks like the following.

image.png.33c2fcd4c9b5610259b25b824ae7def9.png

I have also observed the boards not being offered if the appropriate device family has not been installed.

In the Help menu you can launch the "Add Design Tools or Devices" command.

image.png.e8006a3fecb0e675057abe9822c60606.png

At the first dialog, press next to accept the current installation (eg Vivado HL Webpack). The next dialog allows you to select device families. Make sure the 7 Series and Artix-7 family is selected

image.png.993a88cd94989d5c9d3752f897e7752e.png

 

Also note that the Digilent supported version of Vivado is 2018.2 and not 2018.3. 

 

Edited by kwilber

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
On 3/6/2019 at 3:36 AM, kwilber said:

Vivado is pretty picky about having the correct folder structure. 

On my Centos system, the path to the Arty board files and the contents of the folder looks like the following.

image.png.33c2fcd4c9b5610259b25b824ae7def9.png

I have also observed the boards not being offered if the appropriate device family has not been installed.

In the Help menu you can launch the "Add Design Tools or Devices" command.

image.png.e8006a3fecb0e675057abe9822c60606.png

At the first dialog, press next to accept the current installation (eg Vivado HL Webpack). The next dialog allows you to select device families. Make sure the 7 Series and Artix-7 family is selected

image.png.993a88cd94989d5c9d3752f897e7752e.png

 

Also note that the Digilent supported version of Vivado is 2018.2 and not 2018.3. 

 

 

Edited by CaptIgmu

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

Hi @kwilber,

Thank you for your input! Vivado 2018.3 does work with Ubuntu 18.04 LTS. My confusion came when I did not start with a simple project like blinky. Instead, in the Vivado Quick Start, I selected Open Example Project and tried to do the Base MicroBlaze example. In these templates you can only pick a default Xilinx development board but later in your Project settings you can select your Digilent board but then need to change your IP . . . it is a pain. Instead, if I pick Create Project in the Quick Start, I can then select my arty-a7-35. Also, the Vivado_init.tcl startup file does work and I don't need to add the Digilent board files to .../data/boards/board_files/. The other key issues with Ubuntu 18.04 LTS:  don't use sudo to install Vivado but do use sudo to install the cable drivers!

Spoiler

 

 

Edited by CaptIgmu

Share this post


Link to post
Share on other sites
  • 0

Hi @CaptIgmu,

Glad to hear you were able to get Vivado 2018.3 working on Ubuntu 18.04 LTS! Thank you for sharing what you needed to do to use the Digilent board files.

cheers,

Jon

Share this post


Link to post
Share on other sites
  • 0

Hi @jpeyron,

Thank you for your input! My problem was not usb and cable drivers. The Hardware Manager was able to see my board and djtgcfg enum correctly listed my board. My problem was my confusion about where I could pick my arty-a7-35 board!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now