• 0
jcloiacon

USB Host with Arty Z7 2017.4.1 Prebuilt Images ???

Question

Good morning,

I have spent many hours trying to get a working Arty Z7 board with USB Host capability. In particular, I would like to take input from a class-compliant MIDI device. 

I have created a Petalinux project from https://github.com/Digilent/Petalinux-Arty-Z7-20 repository using the following command:

petalinux-create -t project -s /path/to/Petalinux-Arty-Z7-20-2017.4-1.bsp 

From here, I have simply loaded the pre-built images using a FAT32 SD card. I have plugged various devices (MIDI controller, Flash Drive) into the Arty Z7 USB Host port, none of which seem to be receiving power. "dmesg" output is not effected either. Here is the output of dmesg | grep -i "usb"

root@Arty-Z7-20:~# dmesg | grep -i "usb"
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
usbcore: registered new interface driver usb-storage
e0002000.usb supply vbus not found, using dummy regulator
Found TI TUSB1210 ULPI transceiver.
ci_hdrc ci_hdrc.0: new USB bus registered, assigned bus number 1
ci_hdrc ci_hdrc.0: USB 2.0 started, EHCI 1.00
hub 1-0:1.0: USB hub found
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver

lsusb reveals the following:

Bus 001 Device 001: ID 1d6b:0002

I suppose this is the onboard physical driver?

The device tree, hardware description, and kernel options of this project seem like they should support USB host. 

I'm aware that on other Digilent devices, 5V power had to be forced. I am unable to rectify the voltages present on IC9 with what they should be per the Arty Z7 schematic. In fact, I can't find 5V anywhere on this board?

How must the vanilla Petalinux project or board be modified to power and enumerate USB devices? 

TIA

Edited by jcloiacon

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hello,

We have booted using the bsp you specified. We have used external power (and suggest you to do so), having set the JP5 to REG.

The dmesg messages seem similar in our case to the ones you posted. Also, the first item listed by lsusb is identical to yours.

Obviously we cannot plug the USB device you use (class-compliant MIDI device). We have tried an USB Flash drive, properly recognized as mass storage device. So, everything seems to be OK on our side.

Please read chapter 8 (USB Host) from the reference manual. There are some details about how the USB port behaves. Maybe this is useful for you.

 

 

 

Share this post


Link to post
Share on other sites
  • 0

Thank you for your quick response. 

My board clearly has some hardware problems. IC9 caught fire when I plugged the board in today, and the former input to IC9 is found to be short to input power (12V). 

I suspect regulator IC24 has failed. 

USB device has been successfully enumerated by shorting IC9 pin 1 to IC9 pin 5, and running off 5V USB in power. 

Edited by jcloiacon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now