• 0
MSchleeh

Pmod MTDS Display dark Display after 10-20min

Question

Hello,

i´m currently working on a project using the Digilent Zedboard in combination with the Pmod MTDS Display.

The Display goes through different Bitmap-Images, which are stored on the micro SD-Card of the MTDS. 

After a while the Display shows a black screen, but the Backlight and Touch Functions are still working.

This seems to happen randomly with no correlation to the amount of shown Images or time passed.

Hope someone can help me on that :)

Regards

MSchleeh

 

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Hi @MSchleeh,

1) Which Demo are you running?

2) Or are you using a custom application?

3) Up until the screen goes black on the Pmod MTDS,  does the project works as expected?

thank you,

Jon

Share this post


Link to post
Share on other sites
  • 0

Hi @jpeyron

I created a custom application, in which i use the PmodMTDS_v1_0 library to load Bitmaps from the micro SD card onto the display.

The other parts of my project still works as expected, even when the display screen goes dark.

 

Today i also tested the display with the Demo "MyDispDemo1.cc" and still get the same effect. (Works fine for 10-15 min, before the screen goes dark)

Are there any known issues of the MTDS, that may explain why the display screen goes dark after a while?

thank you for your help,

Maurice

 

P.s Additionally I installed a ferrite choke around the connection cable between the display and the Zedboard to minimize the interferences of high frequency noises.

 

Share this post


Link to post
Share on other sites
  • 0

Hi @MSchleeh,

I have been running the MtdsDemo1 with Vivado 2018.2 using Zedboard and the Pmod MTDS on JD for about 19 hrs as of right now without issues. 

1) Please attach a picture of your physical setup. 

2) Please attach a screen shot of your Block Design.

3) I wouldn't think that the ferrite choke would negatively affect the Pmod MTDS. With that in mind, have you tried using the Pmod MTDS without the ferrite choke?

4) Are you configuring the Zedboard using the usb prog through JTAG Mode or are you configuring the Zedboard using SD or QSPI mode?

5) What are the spec's for the wal-wart you are using to power the Zedboard?

thank you,

Jon

PmodMTDS_time_2.jpg

PmodMTDS_time_1.jpg

Share this post


Link to post
Share on other sites
  • 0

Hi @jpeyron,

3) First I tried the Demo without the ferrite choke and afterwards with the ferrite choke and get same results.

4) Normally i´m using JTAG Mode to configure the Zedboard, additionally i tested the QSPI Mode to programm my Device but in both cases the screen goes black after a while.

5) To Power the Zedboard i´m using this Power Supply: https://www.conrad.com/p/phoenix-contact-uno-ps1ac12dc30w-rail-mounted-psu-din-12-vdc-25-a-30-w-1-x-467507

Today i noticed if i reinitialise the MTDS if the screen goes black by calling mydisp.begin(), the screen goes right back on and works like expected.

(To initialize the Display multiple times i had to modify the mydisp.begin() function, because the value of fInitialized stays true after the first initialization)

mydisp.begin.thumb.png.6a38baf9008f8688d09a5d53cc1b7766.png

 

Here is my Block Design in Vivado 2018.3

BlockDesign.thumb.png.c0439c020230cb960d4f5cbd3eeb035d.png

Physical Setup:

390173518_PhysicalSetup.thumb.jpg.d0e0e69e5ce869356e2178e1a09a840b.jpg

 

Share this post


Link to post
Share on other sites
  • 0

Hi @MSchleeh,

Here is a confirmed Vivado 2018.3 Zedboard/PmodMTDS on JA project. I have been running this project for the last 2 Hrs without issues.  Please try this project and see if you still have the black screen issue. I would also try running your and or the attached  project with the Pmod MTDS directly connected to the Pmod Port.  Another thing would be to try using a different SD card. Not all SD cards are created equal. We have had the best results using Samsung and Scandisk SD Cards.

thank you,

Jon

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.