• 2

Analog Discovery 2 vs Raspberry Pi 3


Question

Hi. I've replaced my Cubieboard with a Raspberry Pi 3, and it runs the ARM version of Waveforms really well. With an Electronics Explorer everything works sweet.

With the AD2, it complains about supply and/or AUX voltage, even with a 5V 3A power pack attached (The power supply panel indicates that the AUX supply is present so I know it is working well). The USB voltage usually shows as 4.92V at a few 10s of mAs

I've tried with 2.5A USB PSU => Pi3 => Powered Hub => AD2, as well as 2.5A USB PSU => Pi3 => AD2. I also get a "unsufficent power". I've tried a few different USB cables too.

The USB 2.0 spec, according to Wikipedia is 5V +/- 0.25V, so anything above 4.75V should be possible. Is there any hints?

If I wanted to make a USB dummy load and test the voltage drop, what specs should I be checking for?

 

Link to post
Share on other sites

Recommended Posts

  • 0

Szia @Andras

I don't know.
With RPI 1B+, 2B, 3B, 3B+ the problem could be related to the 4xUSB hub or its driver. According the reports it is working with model A which has a different USB circuit, as well with other ARM boards.
I hope we will be able to order a 4 B soon to test it.

Link to post
Share on other sites
  • 0

Hi @Grimmers

Thank you for the detailed information.
The failure on USB 2 port is similar to the ones received on previous RPi B models, "Communication error... ERC 0x02" which indicates reading/IN timeout, loss of data in device to host transfers. On previous version the data was more often corruptly received, resulting wrong device status reading, voltage, current...
Lets hope the USB 3 port will be reliable.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now