Question

In Waveforms 3.8.17 (beta), I have encountered a bug in the impedance analyzer when the offset voltage is not zero.

I was measuring the impedance of 10µF capacitors with the adapter board at 100Ω, and I got perfectly fine readings when I used amplitude=1V, offset=0V.

But when I switched to using amplitude=1V, offset=4V, the impedance was reported as essentially infinite (dropping down to maybe 100MΩ around 100kHz). I got this result with several different capacitors, so it is unlikely that poor connections were responsible.  The short and open compensations were redone for the new offset, and seemed to be reasonable.

 Providing a DC offset when testing electrolytic capacitors is essential, and a DC offset is also useful for determining the voltage dependance of ceramic capacitors, so fixing this bug seems to be fairly important.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

If the default setting is just double the amplitude and the same offset, then it should not be called "auto", which implies some sort of intelligent choice.  

Picking a frequency in the middle of the frequency range and making one measurement to determine the output voltage range would be the sensible way to set the range for "auto".

Share this post


Link to post
Share on other sites
  • 0

Hi @gasstationwithoutpumps

You are right.
Initially I wanted the Auto parameter to be determined based on measurements, like in the NA, but in IA adjusting the range/offset might require redoing the open/short compensation, so the Auto option in IA was left on predetermined value.
Thank you for the observation. 

Share this post


Link to post
Share on other sites
  • 0

Ah, I had forgotten that the compensation has to be re-run whenever any parameters are changed.  I wonder, though, how critical that is compared to the errors generated by using the wrong voltage range.

At the very least, the user should be warned that measured voltages are out of range (or at the limits of the range) and that the setting for channel 2 should be changed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now