Question

Hello, 

 

I am getting successfully data from an accelerometer and I then I want to calculate the frequency of a vibrating object where the accelerometer is placed at. As you can observe in the attached VI after I obtain the accelerometer measurements I use data queue function in order to collect a certain amount of data(200), in order to have enough samples for my FFT. Then I use build waveform function and at the end filter and spectral measurements vi. But unfortunately I do not thing that I get the frequency I want.And that means not only that the x axis in waveform graph is not correct but in general when I vibrate the object in certain frequencies the spectrum does not show something close to them.

Can anyone help me?

Thank you

FFT_spectrum.vi

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hi @Parggoo,

I don't believe any of us here at Digilent have LabVIEW 2018, so we're not able to view the VI that you are using; can you post the VI in an older version (2014) or post a screenshot or pdf of what you have?

Additionally so that we can make sure you receive the appropriate support, what accelerometer are you using and are you using any other hardware?

Thanks,
JColvin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now