• 0
pelle

Analog Discovery 2 crashes Macbook Pro when I connect the USB

Question

Hello,

When I connect the Analog Discovery 2 to my Macbook Pro, model 15 inch late 2016, it shows up in WaveForms for a couple of seconds, then the computer shows the crash screen. I thought it was a conflict with FTDI drivers but it seems not to be it. It is connected through an Apple USB-C to USB adapter and I use MacOS Mojave 10.14. Is it someone experiencing the same problem?

Pelle

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

 I used WaveForms v3.8.2 and tried now beta v3.8.18 with the same result. The crash report below is from v.3.8.2:

Spoiler

 

Anonymous UUID:       274A7FB9-7798-7130-DD18-73205FABE985

Wed Oct 24 14:17:54 2018

*** Panic Report ***
panic(cpu 0 caller 0xffffff80080d87bd): Kernel trap at 0xffffff8007d930a0, type 14=page fault, registers:
CR0: 0x000000008001003b, CR2: 0x0000000000000000, CR3: 0x000000000d21b000, CR4: 0x00000000003626e0
RAX: 0xffffff801de73970, RBX: 0x0000000000000004, RCX: 0x0000000000000004, RDX: 0x0000000000000004
RSP: 0xffffff801de738a8, RBP: 0xffffff801de73a20, RSI: 0x0000000000000000, RDI: 0xffffff801de73970
R8:  0x0000000000000000, R9:  0x0000000000000004, R10: 0xffffff800889d7c0, R11: 0xffffff8008658d60
R12: 0x0000000000000004, R13: 0x00000000000000a0, R14: 0xffffff801de7396c, R15: 0xffffff801de738f0
RFL: 0x0000000000010202, RIP: 0xffffff8007d930a0, CS:  0x0000000000000008, SS:  0x0000000000000000
Fault CR2: 0x0000000000000000, Error code: 0x0000000000000000, Fault CPU: 0x0, PL: 0, VF: 1

Backtrace (CPU 0), Frame : Return Address
0xffffff801de73370 : 0xffffff8007faca1d 
0xffffff801de733c0 : 0xffffff80080e6b13 
0xffffff801de73400 : 0xffffff80080d859a 
0xffffff801de73470 : 0xffffff8007f59ca0 
0xffffff801de73490 : 0xffffff8007fac437 
0xffffff801de735b0 : 0xffffff8007fac283 
0xffffff801de73620 : 0xffffff80080d87bd 
0xffffff801de73790 : 0xffffff8007f59ca0 
0xffffff801de737b0 : 0xffffff8007d930a0 
0xffffff801de73a20 : 0xffffff8008625954 
0xffffff801de73a90 : 0xffffff8008626887 
0xffffff801de73ab0 : 0xffffff8008626149 
0xffffff801de73af0 : 0xffffff8008625a49 
0xffffff801de73b30 : 0xffffff7f88f6647a 
0xffffff801de73b80 : 0xffffff8008626887 
0xffffff801de73ba0 : 0xffffff800861ddf9 
0xffffff801de73be0 : 0xffffff8008625ba3 
0xffffff801de73c10 : 0xffffff8008625a49 
0xffffff801de73c50 : 0xffffff7f88f99778 
0xffffff801de73cb0 : 0xffffff8008626887 
0xffffff801de73cd0 : 0xffffff800861ddf9 
0xffffff801de73d10 : 0xffffff8008625ba3 
0xffffff801de73d40 : 0xffffff8008625a49 
0xffffff801de73d80 : 0xffffff7f88f70aee 
0xffffff801de73e00 : 0xffffff8008639c94 
0xffffff801de73ea0 : 0xffffff80086396d4 
0xffffff801de73ec0 : 0xffffff8007fe8865 
0xffffff801de73f40 : 0xffffff8007fe8415 
0xffffff801de73fa0 : 0xffffff8007f590ce 
      Kernel Extensions in backtrace:
         com.apple.iokit.IOUSBFamily(900.4.2)[B3A7BE9C-2002-3891-B7D1-A84CEA0AC9E0]@0xffffff7f88f41000->0xffffff7f88fdbfff
            dependency: com.apple.iokit.IOPCIFamily(2.9)[2CE7BCB3-0766-3A94-A8D4-29BF3EBAEFBC]@0xffffff7f88895000
            dependency: com.apple.iokit.IOUSBHostFamily(1.2)[ED37A531-57CD-313C-B164-BC0F33B09D35]@0xffffff7f88e96000
            dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[7F32C612-AC3B-333C-9067-5EAB39CF6EC3]@0xffffff7f88e8e000

BSD process name corresponding to current thread: kernel_task

Mac OS version:
18A391

Kernel version:
Darwin Kernel Version 18.0.0: Wed Aug 22 20:13:40 PDT 2018; root:xnu-4903.201.2~1/RELEASE_X86_64
Kernel UUID: DF83AD37-501E-3B4F-B1F0-04F3AC90FE35
Kernel slide:     0x0000000007c00000
Kernel text base: 0xffffff8007e00000
__HIB  text base: 0xffffff8007d00000
System model name: MacBookPro13,3 (Mac-A5C67F76ED83108C)

System uptime in nanoseconds: 2538011025353
last loaded kext at 2536884766964: com.digilent.driver.DigilentFtdiDriver    1.1.0 (addr 0xffffff7f8c80d000, size 12288)
loaded kexts:
com.digilent.driver.DigilentFtdiDriver    1.1.0
com.avast.PacketForwarder    2.1
com.avast.FileShield    4.0.0
com.intel.kext.intelhaxm    6.0.5
com.apple.filesystems.msdosfs    1.10
com.apple.driver.AudioAUUC    1.70
com.apple.fileutil    1
com.apple.filesystems.autofs    3.0
com.apple.driver.AGPM    110.23.41
com.apple.driver.ApplePlatformEnabler    2.7.0d0
com.apple.driver.X86PlatformShim    1.0.0
com.apple.driver.AppleUpstreamUserClient    3.6.5
com.apple.driver.AppleHDAHardwareConfigDriver    282.10
com.apple.kext.AMDFramebuffer    2.0.0
com.apple.driver.AppleHDA    282.10
com.apple.kext.AMDRadeonX4000    2.0.0
com.apple.driver.AppleGraphicsDevicePolicy    3.22.18
com.apple.AGDCPluginDisplayMetrics    3.22.9
com.apple.driver.AppleHV    1
com.apple.iokit.IOUserEthernet    1.0.1
com.apple.driver.AppleHIDALSService    1
com.apple.iokit.IOBluetoothSerialManager    6.0.8f6
com.apple.driver.pmtelemetry    1
com.apple.driver.AGDCBacklightControl    3.22.9
com.apple.kext.AMD9500Controller    2.0.0
com.apple.driver.AppleIntelSKLGraphics    12.0.0
com.apple.driver.AppleIntelPCHPMC    2.0.1
com.apple.Dont_Steal_Mac_OS_X    7.0.0
com.apple.driver.AppleBacklight    170.12.11
com.apple.driver.eficheck    1
com.apple.driver.AppleGFXHDA    100.1.23
com.apple.driver.SMCMotionSensor    3.0.4d1
com.apple.driver.AppleMuxControl    3.22.18
com.apple.driver.AppleOSXWatchdog    1
com.apple.driver.AppleMCCSControl    1.5.7
com.apple.driver.AppleEmbeddedOSSupportHost    1
com.apple.driver.ACPI_SMC_PlatformPlugin    1.0.0
com.apple.driver.AppleFIVRDriver    4.1.0
com.apple.driver.AppleIntelSKLGraphicsFramebuffer    12.0.0
com.apple.driver.AppleIntelSlowAdaptiveClocking    4.0.0
com.apple.driver.AppleThunderboltIP    3.1.2
com.apple.driver.AppleFileSystemDriver    3.0.1
com.apple.filesystems.hfs.kext    407.200.4
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless    1.0.0d1
com.apple.BootCache    40
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib    1.0.0
com.apple.AppleSystemPolicy    1.0
com.apple.driver.AppleTopCaseHIDEventDriver    138
com.apple.filesystems.apfs    945.200.129
com.apple.driver.AirPort.BrcmNIC    1400.1.1
com.apple.driver.AppleSmartBatteryManager    161.0.0
com.apple.driver.AppleACPIButtons    6.1
com.apple.driver.AppleRTC    2.0
com.apple.driver.AppleSMBIOS    2.1
com.apple.driver.AppleACPIEC    6.1
com.apple.driver.AppleAPIC    1.7
com.apple.nke.applicationfirewall    190
com.apple.security.TMSafetyNet    8
com.apple.driver.usb.cdc.acm    5.0.0
com.apple.driver.usb.serial    6.0.0
com.apple.kext.triggers    1.0
com.apple.driver.DspFuncLib    282.10
com.apple.kext.OSvKernDSPLib    527
com.apple.kext.AMDRadeonX4100HWLibs    1.0
com.apple.kext.AMDRadeonX4000HWServices    2.0.0
com.apple.iokit.IOAVBFamily    700.6
com.apple.plugin.IOgPTPPlugin    700.7
com.apple.iokit.IOEthernetAVBController    1.1.0
com.apple.driver.AppleSSE    1.0
com.apple.iokit.IOBluetoothHostControllerUARTTransport    6.0.8f6
com.apple.iokit.IOBluetoothHostControllerTransport    6.0.8f6
com.apple.driver.AppleBacklightExpert    1.1.0
com.apple.kext.AMDSupport    2.0.0
com.apple.driver.AppleHDAController    282.10
com.apple.iokit.IOHDAFamily    282.10
com.apple.iokit.IONDRVSupport    530
com.apple.AppleGPUWrangler    3.22.9
com.apple.driver.AppleSMBusPCI    1.0.14d1
com.apple.driver.AppleIntelLpssUARTv1    3.0.60
com.apple.driver.AppleIntelLpssUARTCommon    3.0.60
com.apple.driver.AppleOnboardSerial    1.0
com.apple.iokit.IOSkywalkFamily    1
com.apple.iokit.IOSerialFamily    11
com.apple.driver.AppleGraphicsControl    3.22.18
com.apple.driver.AppleSMBusController    1.0.18d1
com.apple.driver.IOPlatformPluginLegacy    1.0.0
com.apple.driver.X86PlatformPlugin    1.0.0
com.apple.driver.IOPlatformPluginFamily    6.0.0d8
com.apple.AppleGraphicsDeviceControl    3.22.18
com.apple.iokit.IOAcceleratorFamily2    400.24
com.apple.iokit.IOGraphicsFamily    530.9
com.apple.iokit.IOSurface    255.1
com.apple.iokit.IOSlowAdaptiveClockingFamily    1.0.0
com.apple.driver.AppleThunderboltEDMSink    4.1.5
com.apple.driver.AppleThunderboltDPOutAdapter    5.5.7
com.apple.driver.usb.cdc.ecm    5.0.0
com.apple.driver.usb.cdc.ncm    5.0.0
com.apple.driver.AppleUSBAudio    314.28
com.apple.driver.usb.IOUSBHostHIDDevice    1.2
com.apple.iokit.IOAudioFamily    206.5
com.apple.vecLib.kext    1.2.0
com.apple.driver.usb.AppleUSBiBridge    1.0
com.apple.driver.usb.cdc    5.0.0
com.apple.driver.usb.networking    5.0.0
com.apple.driver.usb.AppleUSBHostCompositeDevice    1.2
com.apple.driver.AppleUSBHostMergeProperties    1.2
com.apple.filesystems.hfs.encodings.kext    1
com.apple.driver.AppleActuatorDriver    2400.15
com.apple.driver.AppleHIDKeyboard    208
com.apple.driver.AppleHSBluetoothDriver    138
com.apple.driver.IOBluetoothHIDDriver    6.0.8f6
com.apple.iokit.IOBluetoothFamily    6.0.8f6
com.apple.driver.AppleMultitouchDriver    2400.15
com.apple.driver.AppleInputDeviceSupport    2400.7
com.apple.driver.AppleHSSPIHIDDriver    55
com.apple.driver.AppleThunderboltDPInAdapter    5.5.7
com.apple.driver.AppleThunderboltDPAdapterFamily    5.5.7
com.apple.driver.AppleThunderboltPCIDownAdapter    2.1.4
com.apple.driver.AppleXsanScheme    3
com.apple.driver.AppleHSSPISupport    55
com.apple.iokit.IO80211Family    1200.12.2
com.apple.driver.mDNSOffloadUserClient    1.0.1b8
com.apple.driver.corecapture    1.0.4
com.apple.iokit.IONVMeFamily    2.1.0
com.apple.driver.AppleIntelLpssSpiController    3.0.60
com.apple.driver.AppleThunderboltNHI    4.7.5
com.apple.driver.AppleHPM    3.3.0
com.apple.iokit.IOThunderboltFamily    6.8.1
com.apple.driver.AppleIntelLpssI2CController    3.0.60
com.apple.driver.AppleIntelLpssDmac    3.0.60
com.apple.driver.AppleIntelLpssGspi    3.0.60
com.apple.driver.AppleIntelLpssI2C    3.0.60
com.apple.driver.usb.AppleUSBXHCIPCI    1.2
com.apple.driver.usb.AppleUSBXHCI    1.2
com.apple.driver.usb.AppleUSBHostPacketFilter    1.0
com.apple.iokit.IOUSBFamily    900.4.2
com.apple.driver.AppleEFINVRAM    2.1
com.apple.driver.AppleEFIRuntime    2.1
com.apple.iokit.IOSMBusFamily    1.1
com.apple.iokit.IOHIDFamily    2.0.0
com.apple.security.quarantine    3
com.apple.security.sandbox    300.0
com.apple.kext.AppleMatch    1.0.0d1
com.apple.driver.DiskImages    493.0.0
com.apple.driver.AppleFDEKeyStore    28.30
com.apple.driver.AppleEffaceableStorage    1.0
com.apple.driver.AppleKeyStore    2
com.apple.driver.AppleUSBTDM    456.200.8
com.apple.driver.AppleMobileFileIntegrity    1.0.5
com.apple.kext.CoreTrust    1
com.apple.iokit.IOUSBMassStorageDriver    145.200.2
com.apple.iokit.IOSCSIBlockCommandsDevice    408.200.1
com.apple.iokit.IOSCSIArchitectureModelFamily    408.200.1
com.apple.iokit.IOStorageFamily    2.1
com.apple.driver.AppleCredentialManager    1.0
com.apple.driver.KernelRelayHost    1
com.apple.iokit.IOUSBHostFamily    1.2
com.apple.driver.usb.AppleUSBCommon    1.0
com.apple.driver.AppleBusPowerController    1.0
com.apple.driver.AppleSEPManager    1.0.1
com.apple.driver.IOSlaveProcessor    1
com.apple.iokit.IOReportFamily    47
com.apple.iokit.IOTimeSyncFamily    700.7
com.apple.iokit.IONetworkingFamily    3.4
com.apple.driver.AppleACPIPlatform    6.1
com.apple.driver.AppleSMC    3.1.9
com.apple.iokit.IOPCIFamily    2.9
com.apple.iokit.IOACPIFamily    1.4
com.apple.kec.pthread    1
com.apple.kec.Libm    1
com.apple.kec.corecrypto    1.0

EOF
Model: MacBookPro13,3, BootROM MBP133.0247.B00, 4 processors, Intel Core i7, 2,9 GHz, 16 GB, SMC 2.38f7
Graphics: Intel HD Graphics 530, Intel HD Graphics 530, Built-In
Graphics: Radeon Pro 460, AMD Radeon Pro 460, PCIe
Memory Module: BANK 0/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C31473332443450472D30393320
Memory Module: BANK 1/DIMM0, 8 GB, LPDDR3, 2133 MHz, 0x802C, 0x4D5435324C31473332443450472D30393320
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x15A), Broadcom BCM43xx 1.0 (7.77.61.1 AirPortDriverBrcmNIC-1305.2)
Bluetooth: Version 6.0.8f6, 3 services, 27 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en0
USB Device: USB 3.0 Bus
USB Device: iBridge
Thunderbolt Bus: MacBook Pro, Apple Inc., 37.1
Thunderbolt Bus: MacBook Pro, Apple Inc., 37.1

 


 

Edited by JColvin
Collapsed crash report for readability

Share this post


Link to post
Share on other sites
  • 0

@attila

@pelle

This seems to be related to the issue that another customer reported. I wasn't able to reproduce it on my end and I think it may be an issue that only shows up with newer MAC hardware than I have access to. The driver was originally written using the IOUSBDevice and IOUSInterface classes from IOKIT. At some point Apple deprecated these and drastically overhauled the API, pushing new driver development to use the poorly documented IOUSBHostDevice and IOUSBHostInterface. OSX still includes the dependencies for IOUSBDevice and IOUSInterface which has allowed us to continue using our driver. However I don't think Apple tested all of their newer hardware with those libraries and that's probably why we are seeing crashes that don't occur when running older MAC hardware.

I re-wrote the driver to use IOUSBHostDevice and IOUSBHostInterface, with the hope that doing so may alleviate the crashes. Unfortunately I'm having issues to get it to laod consistently. I asked several questions of Apple Developer Technical support and haven't received any response.

I also filed a bug report against the AppleUSBFTDI with the hope that they will modify their driver so that it will read the EEPROM (if present) and only attach to interfaces that have been configured as virtual COM port interfaces. This is essentially the equivalent behavior of the Windows FTDI driver. Our KEXT does exactly this in the probe function and if the interface is supposed to be VCP then it returns a really high probe score (higher than AppleUSBFTDI) to prevent AppleUSBFTDI from loading so that we can use D2XX. If the interface is supposed to be VCP then we return a probe score of 0 and allow AppleUSBFTDI to attach to the interface. Apple DTS recently sent me an email and asked me to check the functionality of AppleUSBFTDI under OSX Mojave. I haven't yet done this because I needed to use my MAC BOOK pro for testing some FRC stuff. Now that i'm done with that I will upgrade to Mojave and see if they made the changes that I requested. If they modified AppleUSBFTDI in the manner that I requested then it will no longer be necessary to distribute a custom KEXT with Waveforms. I will work on upgrading and get back to you.

Thanks,
Michael

Share this post


Link to post
Share on other sites
  • 0

Hi @malexander

Did you find out if Apple made your requested changes? If it's not changed, can you estimate when it will work in Mojave? I have to return my Analog Discovery 2 if it is not compatible with my computer.

Share this post


Link to post
Share on other sites
  • 0

Hi @pelle

I upgraded to Mojave. It appears that Apple did modify the way AppleUSBFTDI works and I am able to use D2XX without installing a custom KEXT to block AppleUSBFTDI from claiming the interface. You should be able to upgrade to Mojave (if you haven't already) and use Waveforms without installing our custom KEXT. To remove the kext you have to open up a terminal and then use sudo rm -rf to remove our kext from the /Library/Extensions folder. After doing so reboot your machine and then re-run Waveforms with the Discovery attached.

@attila Have you upgraded to Mojave, and if so, can you confirm that the Discovery products are working without the Digilent KEXT? That appears to be the case on mine. If you can confirm this on your end then please remove the KEXT from our Waveforms installer. We can then have support push all customers that are having problems to upgrade to Mojave and remove the custom KEXT.

Thanks,
Michael

Share this post


Link to post
Share on other sites
  • 0

Hi @malexander

I did some tests earlier after removing your driver and it seemed to work as it should. Great to have it confirmed from you.

Thanks,
Pelle

Edited by pelle

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.