• 0
Nadav sholev

Basys3 USB power not working

Question

Hello, 

I just opened my new basys3 board (novice EE student).

As per the documentation I tried to power the board via usb-b (port j4) first through a laptop usb then through a 5v 2A charger making sure the jp2 jumper was set on usb and jp1 to the spi flash test program but the board did not turn on (not even the power good led). 

Trouble shooting that I performed:

1. Changed cable twice (didn't work) 

2. Changed charger and usb ports (didn't work) 

3. Powered board from external 5v power supply - the board worked perfectly. 

My question is could the smd soldering be defective, where can I mesure the voltage provided by the usb? 

Thank you for your help, 

If there is any more information I can provide please let me know 

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hi @Nadav sholev,

Have you tried using a different PC? Or a Powered USB hub? When the board is being powered externally can you see the board in Vivado through the USB UART (mode set to JTAG)? Please use a DMM and measure voltage on the following capacitors while the board is set to power through the usb:

C28 (should be 3V3)

C29(should be 3v3)

 

thank you,

Jon

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now