• 0
melisa

Zybo Z7 Audio Demo upgrade

Question

Hi everyone,

After launching DMA Audio Demo successfully, I was wondering is there any way to process recorded data before playing it back?

The data is stored in AXI Instance with known number of samples (prototype of function: void fnAudioRecord(XAxiDma AxiDma, u32 u32NrSamples);)

I would like to measure energy of my audio signal and show it on LEDs (for example).

 

Any suggestions are well welcomed.

Thanks in advance,

 

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Hi @melisa,

I do not have much experience with processing the recorded data before playing it back. Here is an instructable that might be helpful. I would also look at the nexus video looper demo here as well.

thank you,

Jon

 

 

Share this post


Link to post
Share on other sites
  • 0

Hi @jpeyron,

Thank you for your answer.

After looking in what you have suggested, I tried to implement that Instructable. I found this thread: https://forum.digilentinc.com/topic/1738-how-to-use-audio-on-zybo-board/

i did manage to get everything going in Vivado. But, I got these errors when I import RTOSDemo in SDK. I tried to Regenerate BSP and also to Change Referenced BSP but nothing changes.

 

Thanks,

Melisa

errors.png

Share this post


Link to post
Share on other sites
  • 0

I looked at the project referenced, but couldn't get into it at this time. However, there were a few things that were misleading, at least to me. Specifically, it appears that in step 11, the author has the reader generate a new BSP for standalone, however, all the subsequent references are for FreeRTOS. The illustrations show standalone and no FreeRTOS is shown. This would have lead me to try and make the BSP using standalone parameters even though it was named RTOSDemo_bsp. It also seems that is what happened to you as the SDK is complaining about something not being available for make to include (I can't see the rest of the path).

Have you tried making the new BSP with FreeRTOS selected? Sorry if you've already done this, or I misunderstood what is being attempted.

Share this post


Link to post
Share on other sites
  • 0

Not trying to get in the way of jpeyron's help, as I"m a rank newb here and not trying to step on any toes, I've seen this error before, and I would wait until this can be confirmed as the source and/or a possible solution put forward.

Are you running this on Ubuntu?

It seems make is trying to find a 32 bit tool and/or libs that haven't been installed according to what I've seen.

This is from an old thread...

https://www.microlab.ti.bfh.ch/wiki/huce:microlab:tools:linux-client:xilinx-vivado

arm-xilinx-eabi-gcc

The SDK is shipped with a 32bit compiler so you may need to install 32bit support. Unfortunately, the error in such a case is not very helpful in diagnosing the problem: /opt/Xilinx/SDK/2015.3/gnu/arm/lin??/bin/arm-xilinx-eabi-gcc: No such file or directory

On older systems, the solution would be:

apt-get install ia32-libs

On newer systems, ia32-libs has been made obsolete. You should instead install:

apt-get install lib32z1 lib32ncurses5

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now