• 0

Xively and Chipkit Max32/Network Shield


Question

Hello all

This is related to the current hardware: Chipkit Max32 with Network Shield.

Issue: Xively library files will not work with chipkit max32+ethernet shield.

I have been suffering this change for a while, the MPIDE 2015 release got botched with the arduino update. I had to download the 2015 test release or rely on the totally functional 2013 release. Currently using the MPIDE 2015 test release.

So, later on, getting the Xively library files proved to be difficult to utilize, errors on top of errors.

Other option was to use the chipkit-core library files also available for Arduino IDE. But the network shield fails to operate. Xively library files worked without any errors.

Now, I can either work with xively library files on Arduino IDE or operate the network shield through the MPIDE.

Has anyone figure out if there is a solution for any of my issues? Debugging the code is insane after the update.

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Hi xDR1TeK,

Looking at the Xively page, it looks like they do not support the chipKIT Network Shield, the closest they have is the Arduino WiFi shield, but I suspect that the two shields use different chips (HDG204 on the Arduino shield vs a MRF24 on the chipKIT shield), so it would be very difficult to debug the code to get it working. Since Digilent does not have any connection with Xively, we would only be able to offer limited support for this.

Thanks,
JColvin

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now