• 0
Victor McKeighan

Problem with Digilent dmgr library in Cygwin

Question

First, I'm using Cygwin on a Windows 10 platform to compile and run a utility program that loads a bit file into the serial Flash PROM of a CmodS6 board. The SDK version is Windows v2.4.2, using lib64.

The source code is not my own, but comes from -https://github.com/ZipCPU/s6soc/tree/master/sw/host
and the specific program is zipload.exe

Under Cygwin, all the source code compiles properly. When it is run, a call is made to DmgrEnumDevices() to enumerate any Digilent boards found. Even though the CmodS6 is connected to the PC with USB, it is not enumerated, DmgrEnumDevices() returns 0.

Note: The Digilent utility djtgcfg.exe is able to enumerate the board, initialize, and also configure the Spartan 6.

After the failure to enumerate, a call is made to DmgrSzFromErc() and the error code and information is printed to the screen ---

Victor@Vics_PC /cygdrive/c/Users/Victor/Documents/Sky Engineering/FPGA_Project/ZipLoad
$ ./zipload Top_Level.bit
No CModS6 devices found
ErrCode(3080): ercInternalError
ErrMessage: Internal error.
Segmentation fault (core dumped)

Is there any particular way I have to setup the SDK, other than making sure make can find the include and library files?

I will greatly appreciate any help you can give me.

Vic

deppi.cpp

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hi Jon,

I did as you suggested and ran the EnumDemo program. The result is the same, the program runs and terminates without printing anything. I then added an if statement following the call to DmgrEnumDevices(&cdvc) -

if (cdvc==0)
    {
        printf("No Devices Enumerated.\n");
    }

Then when the program is run, it prints "No Devices Enumerated." to the screen.

Is my configuration (Windows 10, Cygwin, Adept Windows SDK) appropriate for Adept? If not, what should I be using?

Thanks,

Vic

Share this post


Link to post
Share on other sites
  • 0

Jon,

In the 'samples' folder of the SDK I found the document for building an Adept project in Visual Studio. I tried building the EnumDemo, and it worked. So now I need to go back to my original project and see if it can be built in Visual Studio. Will be going out of town later today, but I'll start working on this when I return on Monday.

Vic

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now