• 0
vadim6385

Digilent Adept with JTAG-HS2 cannot save table on Windows 10

Question

Posted (edited)

Hi.

I am trying to get Digilent Adept working on Windows 10 x64 Enterprise (which, as far as I understood, should be supported). 

With Win7 x64, on the same machine, everything is working fine.

On Win10, when I open Adept, I see that no devices are recognized (USB Serial Converter is recognized in Windows Device Manager).

adept1.thumb.PNG.108d930d1ad2218a59705f381c8887c8.PNG

To get it working, I need to go to Adept Device Manager, click Enumerate, get the serial number, give some alias, and click Add Dvc, then Save, after which I get the "Cannot Save Table" message.

Capture.PNG.4795ea5e91f8b22530f90423be8d6607.PNG

When I go back to Adept main window, and click on the "Connect device" drop down box, it is suddenly recognized.

adept3.PNG.ab02206f8c2c34129b8250f63cf5f4e9.PNG

I can use the JTAG-HS2 right until I close the Adept application. If I reboot the system, or just close and reopen Adept, I have to do everything again. Didn't have this issue on Win7.

I have UAC disabled via registry, so it is running in Admin mode (tried to right click > run as administrator, didn't help).

Adept runtime and Application versions are as follows:

adept4.PNG.9cf0fa2e57c431a35c34e52ac0dabc36.PNG

I suspect there is some kind of a compatibility issue of Adept with my version of Windows (10 x64 Ent version 1803)

Can somebody please help?

Thanks,

Vadim

Edited by vadim6385

Share this post


Link to post
Share on other sites

14 answers to this question

Recommended Posts

  • 0
Posted (edited)

Hi @jpeyron

Although I did it before, I did it again, and no, it didn't help.

I also tried to update Java to the latest version, still seeing the same problem.

Edited by vadim6385

Share this post


Link to post
Share on other sites
  • 0

Hi @vadim6385,

The design engineer got back to me. They think it’s some kind of issue with reading the device table file.  They want you to enable debug logging, reproduce the problem again, and then send us the log file.

Please set the following environment variables:

"ADEPT_RT_LOGFILE=C:\some_folder\adept.log"
"ADEPT_RT_LOGDETAIL=1"

You will have to edit the path of the logfile to be the path of a directory that the user account has write permission.

thank you,

Jon
 

Share this post


Link to post
Share on other sites
  • 0

Hi @jpeyron

When I set the program compatibility mode to run as administrator, it generated some kind of log, not in the set directory, but in the Adept directory.

Anyway, the log is attached.

Adept behavior is the same

DebugErc.log

Share this post


Link to post
Share on other sites
  • 0

Hi @vadim6385,

I have passed the path information to one of our design engineers. I will not get a response until early next week due to vacation/holiday. Sorry for the delay.

thank you,

Jon

 

Share this post


Link to post
Share on other sites
  • 0

Hi @jpeyron

I have no idea how, but after I did a reimage of the PC, with clean Win10 Ent. OS, the app started working.

So there was something in my previous installs, that messed up Windows security settings.

Now it seems to be working fine.

 

Thank you for your help,

Vadim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now