• 0
Himanshu

DRP I/O ports connection in XADC and ZYNQ 7000

Question

I am using XADC of Zybo board in DRP mode. I have connected the inputs of the XADC to a potentiometer supplying a voltage in between 0-1 V. I have used the PMOD pins to supply the output to external LEDs. But everytime the  board is programmed, the LED outputs show a garbage value which is constant. Changing the potentiometer voltage does not change the outputs. Also resetting the XADC through GPIO buttons has no effect. 

 

Please help with the above issue.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Actually I want to pass a sinusoidal signal through Vp-Vn pins of the XADC and take the output continuously on external LEDs through pmod pins.

Here is my design. Please check if this is correct.

Also guide me how to get a sampling rate of 1 ksps on the XADC as the lowest conversion rate possible is 39 ksps. I am providing a convst signal of 1 kHz , will that sample at 1 ksps?

xadc1.JPG

xadc2.JPG

Share this post


Link to post
Share on other sites
  • 0

Hi @jpeyron

Thank you for the helpful reply.

But my aim is to give a sine wave to XADC analog input and take its output continuously for 10 cycles. I am using vaux[14] pins ( which are connected to N15 and N16 package pins) for this purpose. But I am getting a garbage value in my output.

Please tell me how to apply the signal and what changes I have to make in XADC configuration.

As shown in the Lab3 design the vaux[0] and vaux[8] pins have been used to take input. My problem is that how to get these ports on the FPGA input-output ports as I have to apply a real time signal to it.

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now