• 0
chcollin

Atlys USB JTAG problem with VirtualBox

Question

Hi FPGA gurus !

I am facing trouble while trying to attach my Atlys USB JTAG device to a Centos 6 virtualbox VM.
I recently had no choice but to upgrade my computer from Windows 7 to Windows 10. As a Windows 10 version of ISE 14.7 was available, I decided I could do the upgrade before realizing that ISE 14.7 for Windows 10 was indeed ISE 14.7 for Linux running a VirtualBox... Nevermind.

The problem is that it seems I can't attach Digilent USB JTAG to the VirtualBox.

Here is my configuration :
Windows 10 Pro
VirtualBox 5.2.8 (I upgraded it so that I could install Extensions to enable USB 2 and USB 3 support)

Adept2 is installed on Windows 10 and works fine, Atlys board is recognized and I can run the test application OK.

Now, here is my problem :

Let's turn on the computer first and do a fresh test !
Atlys Board is attached to USB ports (JTAG and UART) but is turned off.
VirtualBox USB configuration is configured as shown in USB_parameters.jpg
Now, let's turn VM on, Atlys board still off.
The attachable USB device list in VB is shown in USB_devices_atlys_off.jpg
As you can see, neither JTAG nor UART devices are listed, which is expected as Atlys board is off.
Now, let's turn the Atlys board on and see if the listing has changed... It has ! as shown in USB_devices_atlys_on_1.jpg
Also, you can see in Device_mgr.jpg that Windows has no driver problem with JTAG and UART devices.
You may notice UART device is automatically attached.
Looking at /dev/tty* shows that the UART device is now available through /dev/ttyACM0 as shown in TTY_devices.jpg
Let's have a look at the JTAG device status (USB_devices_atlys_on_2.jpg), it reads "captured", whatever that means ...
Now, let's try attaching it...
It raises an error with message shown in Digilent_USB_JTAG_attachment_error.jpg

"USB device is busy with a previous request" :/
This is sad ... Of course, no other device appears in /dev/tty*

Greping dmesg for FTDI pattern returns Nothing. Only UART USB devices appears in dmesg log...

I've tried the same test with USB 3 (xHCI) configuration selected.

Do any of you have an idea on how I could attach the USB Digilent JTAG device to my Centos 6 VirtualBox machine ?

Any help will be highly appreciated. Thanx a lot.
Cheers

Digilent_USB_JTAG_attachment_error.jpg

TTY_devices.jpg

USB_devices_atlys_on_2.jpg

Device_mgr.jpg

USB_devices_atlys_on_1.jpg

USB_devices_atlys_off.jpg

USB_parameters.jpg

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Hi @chcollin,

I do not have much experience resolving usb issues with VM's. I would guess it has to do with the VirtualBox USB configuration. I would look through this forum thread for some trouble shooting suggestions.

thank you,

Jon

Edited by jpeyron

Share this post


Link to post
Share on other sites
  • 0

Hi @jpeyron

Thanks a lot for the link.
Whatever I tried, I never managed to solve the problem. I finally ended up setting a new linux native partition on which I installed Centos 6.9.

It's been a very hard time making Xilinx EDK work flawlessly (I had to install i686 libs, update cairo libs, recompile usb cable drivers, change serial port access libs ...), but I finally have a fully working ISE 14.7 setup, no SDK  crashes, JTAG and UART via USB working :D

Happy !

Edited by chcollin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now