• 0
shahabamo

JTAG-HS2 firmware erased by accident

Question

Hello,

My JTAG HS2 firmware accidentally erased while i was trying to program another FTDI device connected to the PC and the programmer is not detected anymore by Xilinx Impact. 

Please help me how to recover it?

Share this post


Link to post
Share on other sites

27 answers to this question

Recommended Posts

  • 0

I have sent you on your e-mail the link to the repair utility and the instructions.

Since this application should only be used just in emergency situations like this one, we prefer to keep in some kind of "shadow" and we don't want to have it posted on the forum. We provide it when requested.

shahabamo likes this

Share this post


Link to post
Share on other sites
  • 0

Hi everyone,

I've just made the same mistake, instead of another FTDI chip, I erased JTAG-HS2. Could someone help me with this?

Share this post


Link to post
Share on other sites
  • 0

Hi @Franco,

Sorry for the late response. I was out of office for a week. I will provide you the application in case no one attended you until now.

Best regards,

Bianca

Share this post


Link to post
Share on other sites
  • 0

Hi.

I have the same problem. I also reprogrammed ftdi and JTAG-HS2. I did not change anything, but after reading and writing the device is not detected as a programmer.

Please help.

Share this post


Link to post
Share on other sites
  • 0

Hi,

My Digilent Jtag HS2 programmer Cable has been broken by wrong power, I have changed the ft232hq chip on the board,

Pc has recognized the Cable Digilent Jtag HS2 but FTPROG has no xml file therefore Impact has not recognized it,

Could you please send me FtProg Config File (xml) ?

Best Regards,

C.Albayrak

Share this post


Link to post
Share on other sites
  • 0

I appear to have done the same thing with my HS2 Rev A cable.

I was using FT prog to flash something else and have erased my JTAG cable in the process. How do I got about getting it restored?

Thanks

Tom Reap

Share this post


Link to post
Share on other sites
  • 0

Hello, @Cristian.Fatu, @Bianca

I have the same problem. 

I use the JTAG-SMT1 mounted on the Xilinx Kintex-7 evaluation kit (KC705).

I accidentally programmed the JTAG-SMT1 using FT_prog incorrectly.

Can I recover it?

 

Best regards,

Jun Yeon

Edited by Jun Yeon

Share this post


Link to post
Share on other sites
  • 0

Hi Digilent,

 

I have same issue when I tried to change serial number of HS2 Rev A. Now I am not able to detect JTAG through my application.

When I see through FT_Prog hex output I see that some fields got erased. Can you help. ?

 

Thanks in Advance,

Deepak

Edited by Deepak Srirama Bairy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now