Search the Community

Showing results for tags 'uc32'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News
    • New Users Introduction
    • Announcements
  • Digilent Technical Forums
    • FPGA
    • Digilent Microcontroller Boards
    • Non-Digilent Microcontrollers
    • Add-on Boards
    • Scopes & Instruments and the WaveForms software
    • LabVIEW
    • FRC
    • Other
  • General Discussion
    • Project Vault
    • Learn
    • Suggestions & Feedback
    • Buy, Sell, Trade
    • Sales Questions
    • Off Topic
    • Educators
    • Technical Based Off-Topic Discussions

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 21 results

  1. What is the difference between the original UC32 (now retired) and the UC32 REV B (and what is the difference - I'm at work don't have my board in front of me)? Thanks, BillyBoy
  2. Hello, I'd like to know if it's possible to program chipKIT uC32 in pure C using MPLAB X IDE? Is there a licensed debugger I must to choose when creating MPLAB project? Thanks.
  3. Hello, I was hoping to use your uC32 board to control 4 stepper motor drivers and to provide debug information over serial back to a PC. Unfortunately though the UART routine implemented in HardwareSerial only has a buffered RX implementation and not a buffered TX implementation. This means that at lower baud rates or with larger debug payloads the time to send the data into the serial line can take a rather long time. I looked around online and I can't find any pre-built libraries that implement an IRQ based UART TX Buffer on the PIC32 that would be compatible with the framewor
  4. Hello and thanks for taking the time to read my question. I'm hoping to use the ADC functionality of the chipkituC32 but I have some questions. As I understand it, when I write the command Input = analogRead(A3) I should get an interger number 1023 /3.3 = x . However when I have no input into the A3 port, I get the constant number 788. How do I do the correct conversion? When I was sending in a DC voltage of 2 V I was getting alternating numbers between 600 and 1023 which make no sense. Also, I cannot find in the datasheet, what is the frequency to read in a signal? I found somewh
  5. Hello, i am having trouble using the chipkit uc32 together with the analog shield here : https://store.digilentinc.com/analog-shield-high-performance-add-on-board-for-the-arduino-uno-retired/ When i connect the Shield to my Arduino UNO one samples needs about 10 microseconds witch should be right. Instead if i connect it to the chipKit uc32 it takes about a 150 microseconds. I guess the SPI communication is not working properly but i dont know why. Since i dont know wether the board is the retired version or the newest i thought it might not work if its the old one.
  6. Good evening! I am trying to use an Adafruit BNO055 breakout board with a ChipKit uC32 board, but there’s some kind of underlying bug causing the initialization code to fail. I’ve tracked it down to how the reset of the BNO055 is happening, but I’ve hit a wall at how to go deeper. Any advice would be welcome. Hardware used: Adafruit Feather Bluefruit LE Digilent ChipKit uC32 Adafruit BNO055 orientation board breakout Breadboard, wires, etc. Photos of hardware setup attached. To start, I tested using the BNO055 and the Adafruit sensorapi example sketch o
  7. Dear Digilent Support Staff,I'm a graduate student at the University of Arizona, and for my Master's Project, I'm designing an irrigation process control system. I'm using a Digilent UC32 microcontroller to read whether or not a switch from a relay contact from a flow meter is either open or closed. I will be using a 5 V power supply, and have read that the digital input pins on the Digilent UC32 can handle 5V at logic levels. I have a few questions: What is the maximum current that is safe for the UC32's digital pins to handle? Do the digital pins have a built-in resist
  8. I have been trying to get the pmodIA working with the chipKIT uC32 using MPIDE 0150. After hooking the I2C pins on the pmodIA to the uC32's dedicated I2C pins on J11, Vcc to 5V or 3.3V, etc. , successfully uploading the example sketch to the board and running the IA_Test() function, the session fails to proceed upon trying to interact the pmodIA. I downloaded and installed the associated libraries and such about a week ago. Here is what I've been getting on the serial monitor: PmodIA Demo Press 'r' when ready!! IN test 128 Then nothing else happens, presumably due to th
  9. I recently purchased the chipkit UC32 from digilent to do a labview project but when I connect it to my Windows 10 laptop, it says “USB device not recognized”. In the device manager of my computer I see the error in the port under Universal Serial Bus Controllers and it has the yellow triangle error symbol next to “Unknown USB Device (Device Descriptor Request Failed)” I have tried many things to try and get it working but have failed. Please help
  10. Monics

    Ethernet shield

    I am looking at using the Digilent modules together with Labview LINX (Makerhub), and I need a setup with ethernet connection to Labview/LINX. Digilent have retired the 410-211, Network Shield... but will I be able to use the Pmod NIC100 (together with max32 or uC32) and get support for ethernet interface through LINX....?Br,Martin Christiansen.
  11. Hello there! I am a newbie using ChipKit uC32, and wonder what is the meaning of underscored pins on J5 and J6. Pins 3, 5,6,9,10 May I use all J5 and J6 pins as I/O? Thanks in advance for any help.
  12. Has anyone gotten a 40 pin tft to work with a uC32? I have tried two different 40 pin tfts both with and without a shield and failed. I have been attempting to use the UTFT library. Both tfts work ok with shields on an AATAmega256 and a DUE. I am also compiling with MPIDE 0023-windows-20140821. I have heard there are some displays that do work Nokia 5110 and one other. But I feel their resolution is too small a foot print for my project. I'm looking for a minimum of 240x320. If you have a solution please provide links to hardware and software libraries required. Thanks
  13. This may be the worst of the noob questions. I just purchased an uc32 as an upgrade to my use of arduino to get something more powerful and upon using the 1.6.8 arduino ide, the first sketch that I try to push to the board gives a "cannot erase chip" error. Thoughts? David --cut-- Sketch uses 19,096 bytes (3%) of program storage space. Maximum is 520,192 bytes. Global variables use 6,316 bytes of dynamic memory. Programmer for Microchip PIC32 microcontrollers, Version 2.0.186 Copyright: (C) 2011-2015 Serge Vakulenko Adapter: STK500v2 Bootloader
  14. Hello, I have a compile error with the SoftwareSerial library included in ChipKit-core 1.1.0.-18 (the latest released build for manual install at this time). I need the SoftwareSerial.h library for several external devices, but it will not compile the headers on ChipKit boards. I am able to build against the Arduino and Adafruit boards, but all of the Cerebot and ChipKit boards exhibit the same error. Any help would be appreciated. Environment: Arduino IDE 1.6.8 ChipKit-core 1.1.0-18 (latest release build manually installed, also exposed error in 1.1.0.-13)) uC32 (b
  15. I'm very confused as to why I can't get 3 GPIO's to work as desired. I'm trying to program 3 external shift registers. The control lines are Clk, Latch, Output Enable and Data In. I've implemented a ~240Hz timer to cycle between 4 16-bit values to be sent to the shift registers. Everything works except the 3 data inputs. The actual failure is the bit shifting and mask of each of the 16-bits of the 3 data in variables. I'm including my code and an analyzer trace (uc32 pins directly to a Saleae logic analyzer). I'd appreciate anyone that could shed some light. Thanks!
  16. Hi, I was wondering, Since Arduino IDE 1.6.5 with chipkit-core-windows.16778039.v1.0.0-27-gdfa0309 cannot erase the memory of the ChipKit uC32 but the MPIDE can. Is there a way to extract the bootloader version from the ChipKIT? I mean any ChipKIT since I have three flavors in front of me? I do not have a programmer thought. Luc
  17. Hi guys, I'll looking to use 3 of the 5 compare pwm outputs available on the uC32. I would like to use them to generate 3 square waves all around 830Hz. They'll all be fixed frequency from the start of the program. I've seen the sample code in the datasheet, but I think there must be easier higher level functions I can call. I would like to send the output on the OCx pins. Can anyone point me in the direction of some resources for this? I can't seem to get anything out of the OC pins. Thanks, djcheezy
  18. I have a uC32 I purchased a month ago from Adafruit. Over the last week I have been unable to get it to work with several tfts that work on Arduinos, with or without a shield. I have exchange several emails with Hemning K. And he can not figure it out. I have also run continuity tests on all pins. Yesterday I receive a wifi shield from you and it fails to scan wifi networks. The http server example reads the ad card but stops on the scan. I did modify the config file for my said and password and changed the security type for pass phrase. Any suggestions you can make on how I debug furth
  19. I have had these microcontrollers from Digilent for some time but have never needed the Vref+ pin until now. From my understanding, it should be on the ADC or somewhere near it on the PIC32 pins. I have tried looking through the datasheets and have only found that pin42 on the UC32/IO-shield is the correct pin for the Vref+. I also tried calling and had recieved no help there. Can anyone help me locate the Vref+ pin as I am using this as the reference input to the micro-controller. The board is a PIC32MX340f512h
  20. JColvin

    uC32 Analog Ref

    From the album: Forum photos

    Location of Analog Vref+ voltage pin, pin 42
  21. Hi, How do you get the UART mode on the PmodMAXSONAR to work correctly? While using the provided demo code, I am able to get the PWM and Analog modes to report correct distances, but I seem to be having trouble to get the UART version to work. What pin(s) should I be using? Thanks, James